Searching messages for tags doesn't fully work

RESOLVED FIXED

Status

MailNews Core
Backend
--
major
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Karsten Düsterloh, Assigned: Bienvenu)

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

1.19 KB, patch
(not reading, please use seth@sspitzer.org instead)
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
Thunderbird Mac/SeaMonkey Windows nightly of 2006-06-13

Search messages is broken when searching for tags:
- tag one message in a folder as Later and Work, using former labels
- tag another one there as Important, Later and Work
- open Search Messages dialog, search in that folder for [Tag][contains][Work]

Results: none
Expected results: both above messages

- search again, this time for [Tag][contains][Later]

Results: message one from above
Expected results: both above messages

- search again, this time for [Tag][contains][Important]

Results: second message from above, as expected

It seems that only the tags whose internal keywords are alphabetically first are found?
(Assignee)

Comment 1

12 years ago
I'll look into it.
Assignee: nobody → bienvenu
(Assignee)

Comment 2

12 years ago
Created attachment 225769 [details] [diff] [review]
proposed fix

need to use length of keyword we're looking for, not the length of the whole string, when looking for blank. So the search was failing on any but the first keyword.
Attachment #225769 - Flags: superreview?(sspitzer)
Comment on attachment 225769 [details] [diff] [review]
proposed fix

sr=sspitzer, acting sr for mailnews while mscott is away
Attachment #225769 - Flags: superreview?(sspitzer) → superreview+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.