Live bookmarks expects GUID in RSS 2.0 feeds as valid URL

RESOLVED DUPLICATE of bug 260918

Status

()

--
minor
RESOLVED DUPLICATE of bug 260918
13 years ago
13 years ago

People

(Reporter: bugs, Unassigned)

Tracking

1.5.0.x Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.4) Gecko/20060605 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.8.0.4) Gecko/20060605 Firefox/1.5.0.4

Live Bookmarks are treating the GUID element as a valid URL (which is not necessarily the case)

At this following RSS feed:
http://planet.gentoo.org/rss20.xml
All items possess the GUID and Link elements. However only in some cases are the GUID elements valid URLS (many contain the @ symbol).

Based on the RSS 2.0 Specification (http://blogs.law.harvard.edu/tech/rss), the GUID element of an RSS 2.0 feed is only a valid URL if the 'isPermaLink="true"' attribute is specified. The primary purpose of the GUID is to provide a unique identifier.

Reproducible: Sometimes

Steps to Reproduce:
1.Create a Livebook mark to http://planet.gentoo.org/rss20.xml
2.Try accessing several items of the live bookmark. Many of these links will not load properly because the GUID used for a link is not a valid URL (nor does it have to be based on the spec)


Actual Results:  
Many GUIDs at http://planet.gentoo.org/rss20.xml contain an @ symbol. This is invalid in URLs.

Expected Results:  
Live bookmarks should only treat GUIDs as URLs if the 'isPermaLink="true"' attribute of the GUID element is specified. Otherwise the Link element should be used.
(Reporter)

Comment 1

13 years ago
This is within the 1.5.0.x branch.
Forgot to add that info...
Version: unspecified → 1.5.0.x Branch
Unfortunately, you have to read every single word of http://blogs.law.harvard.edu/tech/rss#ltguidgtSubelementOfLtitemgt including "its default value is true" - <guid> == <guid isPermaLink="true">

Please evangelize them to update to the current 1.0 branch that ought to be a release if Jeff would ever get to it, assuming the template is fixed for that, or just to add a |isPermaLink="false"| in their RSS 2.0 template.

*** This bug has been marked as a duplicate of 260918 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.