Alt + arrow shortcuts for Back and Forward broken

RESOLVED WORKSFORME

Status

()

Core
Keyboard: Navigation
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: skierpage, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060613 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060613 Minefield/3.0a1

In today's nightly update 2006061305, I noticed using Alt + Left Arrow to go back is broken.  History > Back still works.  Same for Alt + Right Arrow for forward.

Reproducible: Always

Steps to Reproduce:
1.  Surf around
2.  Press <Alt + Left Arrow>


Actual Results:  
Nothing happens.

Expected Results:  
Shortcut for Back

The 2006061316 respin doesn't fix this.
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060613 Minefield/3.0a1 (build 1.9a1_2006061321)
*** Bug 341482 has been marked as a duplicate of this bug. ***

Comment 3

12 years ago
there is an WARNING when I press alt-arrow:
WARNING: Event handler object not a function: file ../../../../src/mozilla/dom/src/base/nsJSEnvironment.cpp, line 1692

seems a regression caused by check-ins of nsJSEnvironment.cpp
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

12 years ago
Seems to be fixed on linux:
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a1) Gecko/20060614 Minefield/3.0a1
(Reporter)

Comment 5

12 years ago
Works for me too with next nightly update
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060614 Minefield/3.0a1 ID:2006061405 [cairo]

Marking FIXED (Should only the engineer who fixed the bug mark it FIXED?)
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
No specific bug / patch referenced as the fix.

-> WORKSFORME
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

12 years ago
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.