Merge the banner and header

RESOLVED FIXED in Bugzilla 3.0

Status

()

Bugzilla
User Interface
--
enhancement
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: glob, Assigned: glob)

Tracking

unspecified
Bugzilla 3.0
Bug Flags:
approval +

Details

(URL)

Attachments

(1 attachment, 3 obsolete attachments)

(Assignee)

Description

12 years ago
Having both the banner and the header is redundant, they should be merged.

Updated

12 years ago
Target Milestone: --- → Bugzilla 2.24
(Assignee)

Comment 1

12 years ago
Created attachment 225559 [details] [diff] [review]
merge banner and header, v1

drops the banner completely and displays content that was in the header in a similar style to how the banner looked.

http://landfill.bugzilla.org/header/
Attachment #225559 - Flags: review?(LpSolit)

Comment 2

12 years ago
Comment on attachment 225559 [details] [diff] [review]
merge banner and header, v1

>Index: template/en/default/global/header.html.tmpl

>+[% PROCESS "global/common-links.html.tmpl" no_find = 0 %]

Nit: "no_find = 0" is old code (in fact, the corresponding code never landed in common-links.html.tmpl) and should be removed.

Note to the one doing the checkin: banner-html.tmpl must be dropped.

r=LpSolit
Attachment #225559 - Flags: review?(LpSolit) → review+

Updated

12 years ago
Status: NEW → ASSIGNED
Flags: approval?

Comment 3

12 years ago
Looks like skins/standard/global/header.png isn't required anymore. We should also remove it on checkin.
Oh no... I use custom banner.html.tmpl a lot. If you merge them with header.html.tmpl, I'll need to use custom header.html.tmpl. Now header.html.tmpl is bound to change more often than banner.html.tmpl, so I'll have a harder time upgrading Bugzilla.

I don't like this bug :(
(In reply to comment #4)
> Oh no... I use custom banner.html.tmpl a lot. If you merge them with
> header.html.tmpl, I'll need to use custom header.html.tmpl. Now
> header.html.tmpl is bound to change more often than banner.html.tmpl, so I'll
> have a harder time upgrading Bugzilla.

This is a good point.  Installations regularly customize the Bugzilla banner, and the Bugzilla navigation bar is likely to change over time.  Putting the two together in the same template means that installations with customized banners will have to check for and merge changes between the standard template and their custom template every time they update.

Seems like we should avoid that by keeping the banner in a separate file, even as we make whatever other changes the patch is making.
Flags: approval? → approval-

Comment 6

12 years ago
<myk> LpSolit: i like the new UI; that's not the problem; i just want to make sure we address the issue of custom banners; perhaps you could chat with Marc (wurblzap on IRC, i think) and work out how best to support custom banners in the new UI

Comment 7

12 years ago
Marc, would it be enough if we let [% INCLUDE global/banner.html.tmpl %] in header.html.tmpl but clear all the text from banner.html.tmpl?
(In reply to comment #7)

That'd make it include a custom banner.html.tmpl file, if present. So yes, I'm ok with this. Will it pass runtests.pl if you [% PROCESS %] a template which doesn't exist? (Or will you leave an empty file?)

Comment 9

12 years ago
(In reply to comment #8)
> ok with this. Will it pass runtests.pl if you [% PROCESS %] a template which
> doesn't exist? (Or will you leave an empty file?)

Probably we could leave it with a simple <div> </div> in it. Maybe with an id=. glob?
(Assignee)

Comment 10

12 years ago
Created attachment 225870 [details] [diff] [review]
hidden banner

this version includes the original banner and hides with with css.
Attachment #225559 - Attachment is obsolete: true
Attachment #225870 - Flags: review?
(Assignee)

Comment 11

12 years ago
Created attachment 225871 [details] [diff] [review]
empty banner

this version includes the an empty banner.
Attachment #225871 - Flags: review?
(Assignee)

Comment 12

12 years ago
i don't know how far you intend to support customizations to bugzilla, so here's two versions for you to choose from.

for the record i prefer the original.  if you customise any opensource project, you have to expect updates to break your customisations.

Comment 13

12 years ago
Marc, which version do you prefer?

Comment 14

12 years ago
One thing I noticed: it's very hard to see the bug number (as link) in the banner when editing an attachment (the link is either dark blue or violet, and the banner itself is dark already). glob, could you please fix that?
(Assignee)

Updated

12 years ago
Attachment #225870 - Attachment is obsolete: true
Attachment #225870 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #225871 - Attachment is obsolete: true
Attachment #225871 - Flags: review?
(Assignee)

Updated

12 years ago
Blocks: 341869
(Assignee)

Comment 15

12 years ago
Created attachment 226106 [details] [diff] [review]
empty banner v2

fixes links in the titles (always white now)
incorporates fix for bug 341869 (dropping h1/h2/h3)
Attachment #226106 - Flags: review?
Um, what's the point of this, and what do we gain by doing this?

I'm still skeptical.

So does this new version basically provide an installation with no banner at all in a default install? (so you have nothing but the navigation bar and the page title at the top?)
(Assignee)

Comment 17

12 years ago
> Um, what's the point of this, and what do we gain by doing this?

screen space, flexibilty.

there's no need to have a banner that just says "this is bugzilla", when that information is already in the title.  the patch ensures that the first word of the title is always terms.bugzilla.
 
> So does this new version basically provide an installation with no banner at
> all in a default install? (so you have nothing but the navigation bar and the
> page title at the top?)

yes, but the styling of the page title matches the current banner, so you're not losing it as such.
(Assignee)

Comment 18

12 years ago
> flexibilty.

what i mean by this is right now it's hard to change the "bugzilla" text in the banner because its implemented as an image.

Comment 19

12 years ago
Comment on attachment 226106 [details] [diff] [review]
empty banner v2

(In reply to comment #12)
> i don't know how far you intend to support customizations to bugzilla, so
> here's two versions for you to choose from.
> 
> for the record i prefer the original.  if you customise any opensource project,
> you have to expect updates to break your customisations.

I agree that hiding the original code is better than removing it because new customizers appreciate an in-line example.  I also like the coding of your latest attachment.  I don't see any down side to removing the "This is Bugzilla" notice, but I am wondering why you chose to make Bugzilla look different in IE vs. FF/Moz. in some of your style statements?
Attachment #226106 - Flags: review?(justdave)
Attachment #226106 - Flags: review?
Attachment #226106 - Flags: review+
(Assignee)

Comment 20

12 years ago
> Bugzilla" notice, but I am wondering why you chose to make Bugzilla look
> different in IE vs. FF/Moz. in some of your style statements?

the only change ie/ff specific change that i've introduced is using the -moz-border-radius styling (which ie doesn't support of course).

i've left any existing css selection tricks intact.

Comment 21

12 years ago
Bugzilla 3.0 is going to have a complete new UI. I see no reason to be compatible with current customisations.
Flags: approval- → approval?
ok, why not?  We can screw with it again later since we're redoing UI before release anyway.
Flags: approval? → approval+
(Assignee)

Updated

12 years ago
Attachment #226106 - Flags: review?(justdave)
(Assignee)

Comment 23

12 years ago
Checking in sanitycheck.cgi;
/cvsroot/mozilla/webtools/bugzilla/sanitycheck.cgi,v  <--  sanitycheck.cgi
new revision: 1.117; previous revision: 1.116
done
Checking in skins/standard/global.css;
/cvsroot/mozilla/webtools/bugzilla/skins/standard/global.css,v  <--  global.css
new revision: 1.22; previous revision: 1.21
done
Checking in template/en/default/index.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/index.html.tmpl,v  <--  index.html.tmpl
new revision: 1.28; previous revision: 1.27
done
Checking in template/en/default/admin/params/editparams.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/admin/params/editparams.html.tmpl,v  <--  editparams.html.tmpl
new revision: 1.3; previous revision: 1.2
done
Checking in template/en/default/bug/show.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/bug/show.html.tmpl,v  <--  show.html.tmpl
new revision: 1.13; previous revision: 1.12
done
Checking in template/en/default/global/banner.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/banner.html.tmpl,v  <--  banner.html.tmpl
new revision: 1.10; previous revision: 1.9
done
Checking in template/en/default/global/header.html.tmpl;
/cvsroot/mozilla/webtools/bugzilla/template/en/default/global/header.html.tmpl,v  <--  header.html.tmpl
new revision: 1.42; previous revision: 1.41
done
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Keywords: relnote

Comment 24

11 years ago
Added to the release notes on bug 255155.
Keywords: relnote

Comment 25

11 years ago
The correct bug number for those release notes is actually bug 349423.

Comment 26

11 years ago
Comment on attachment 226106 [details] [diff] [review]
empty banner v2

>+    #titles #title
>     {
>         font-weight: bold;
>+        white-space: nowrap;
>     }
This seems to have recreated bug 234943 for Bugzilla 3 :-(
Should I file a new bug on Bugzilla 3, or retarget the old one?
(Assignee)

Comment 27

11 years ago
> This seems to have recreated bug 234943 for Bugzilla 3 :-(

oops.

> Should I file a new bug on Bugzilla 3, or retarget the old one?

file a new bug please.

Updated

11 years ago
Duplicate of this bug: 375167
You need to log in before you can comment on or make changes to this bug.