Button for highlighting search terms

VERIFIED WONTFIX

Status

Camino Graveyard
Toolbars & Menus
--
enhancement
VERIFIED WONTFIX
12 years ago
12 years ago

People

(Reporter: trainpassenger, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.0.3) Gecko/20060427 Camino/1.0.1

With Google Toolbar for Firefox and WinIE, it's possible to press a button to highlight all the search terms you entered in the search box. Each search term then gets highlighted in different colors. I think this is _a lot_ faster and more practical than "Find In Page" or "Find As You Type".

There is a bookmarklet that mostly does the same, but since bookmarklets isn't an ideal solution, it would be better if this was integrated in the browser IMHO. Link to bookmarklet: http://www.gizmometer.com/blog/?p=14

Thanks.

Reproducible: Always
This might be an interesting addition to the Find panel.
(Reporter)

Comment 2

12 years ago
>This might be an interesting addition to the Find panel.

I was thinking that it's more practical to place such a button beside the search box. Then you can even use the search box for "Find In Page" instead, which is how it works in Google Toolbar.

Comment 3

12 years ago
And why, exactly, aren't bookmarklets an ideal solution here?

Mac OS has never supported non-contiguous text highlight. Users will expect highlighted search terms to behave just like any other text selection, responding to pasteboard actions like Copy and Cut. If we use the system highlight colour to do it, which is how it currently works, this has the potential to confuse people.

If we don't use the system highlight colour, and since Mac OS doesn't support non-contiguous selection anyway, how is doing this on our own any better than a bookmarklet?

cl
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> And why, exactly, aren't bookmarklets an ideal solution here?

1. Because it's much better to have a button e.g. beside the search box, than placing a bookmarklet in the bookmark bar -- which isn't really intented for bookmarklets at all. A seperate button would be much more user friendly and accessible.

2. The bookmarklet cannot make use of the search box if you already are in a page, and you decide you want to highlight something in that page.

3. If you do a search in Google and use "OR" or "AND" between search terms, the bookmarklet in question will highlight those words too. It even highlights words like "a" and "the". Google Toolbar doesn't do this.


> Mac OS has never supported non-contiguous text highlight. Users will expect
> highlighted search terms to behave just like any other text selection,
> responding to pasteboard actions like Copy and Cut. If we use the system
> highlight colour to do it, which is how it currently works, this has the
> potential to confuse people.

Doesn't anything have the potential to confuse people? I honestly don't this is somehing to worry about.

Comment 5

12 years ago
(In reply to comment #4)

> (In reply to comment #3)
> 
> > Mac OS has never supported non-contiguous text highlight. Users will expect
> > highlighted search terms to behave just like any other text selection,
> > responding to pasteboard actions like Copy and Cut. If we use the system
> > highlight colour to do it, which is how it currently works, this has the
> > potential to confuse people.
> 
> Doesn't anything have the potential to confuse people? I honestly don't this is
> somehing to worry about.
> 

I do think it would be bizarre to use a system selection highlight.  The words aren't being selected, after all.  But they can be highlighted in some other color, as Google Toolbar does.

Comment 6

12 years ago
I agree that highlighting is different from selection.  Find in page selects, what this wants is highlighting, and for that reason I don't think this should be incorporated into our Find in page feature.

As far as I'm concerned, this might be a nice ability to have (maybe bookmarklets are the ideal solution?  maybe some other way?), but I don't think it belongs as part of cmd-f.

Comment 7

12 years ago
(And if it's not part of Find in page, I guess it's either WONTFIX or a dupe of bug 258211)

sorry for the bugspam.

Comment 8

12 years ago
WONTFIX per IRC and above discussion.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX

Comment 9

12 years ago
Oh, another reason this is a WONTFIX: it's not something that Camino should have to worry about. If Core decides to add this functionality to find-in-page or type-ahead find, then we should get it for free (or minimal effort).

There's no reason to spend lots of time and effort rolling our own solution, though.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 10

12 years ago
Bug reopened, because I want to make sure you understand me correctly.

This has _nothing_ to do with Find In Page or FAYT. All I'm suggesting is making an _optional_ toolbar button that functions more or less like the bookmarklet mentioned above.

Now, feel free to mark as WONTFIX.
Status: VERIFIED → UNCONFIRMED
Resolution: WONTFIX → ---

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WONTFIX

Comment 11

12 years ago
I understand you perfectly well.

This is not going to happen unless Core adds it.

cl
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.