Extensions causes wrong align layout on window.open() pop-up screens on HTTPS.

RESOLVED DUPLICATE of bug 204743

Status

()

RESOLVED DUPLICATE of bug 204743
13 years ago
11 years ago

People

(Reporter: rob.hva, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

I develop webenvironments myself using WebSphere Application Developer. While devolping a calendar pop-up which is called by the javascript window.open(). I have noticed this strange situation. On the localhost (which is HTTP) the pop-up screen is working normaly. But while testing it on our development server (which is HTTPS) the text align of the div tag´s and the align of the tables where not working properly.

Back to the localhost I changed it into HTTPS as well and now the alignment was not working correctly as well. But with my collegue is was working. I have noticed that a few popular extensions like the Gmail notifier and Tabmix plus is causing this problem. After uninstalling these is was working correctly on my own environment as well.

Summary:
I think some extensions will cause layout problems in combination with HTTPS, why? I have no idea. I hopeyou can work on this.

Reproducible: Always

Steps to Reproduce:
1. Install a few extensions like gmail notifier and tabmix plus.
2. create a popup window with a <div style="text-align: center; margin:0 auto; position:relative;"> or <table align="center" cellpadding="0" cellspacing="0" border="0">
2. Create an open script like: window.open('width=280,height=360,alwaysRaised=yes,left=560,top=260');
3. use this within a HTTPS and an HTTP environment to see the align differences.

Actual Results:  
on HTTPS the alignment is not working properly

Expected Results:  
on HTTP the alignment is working properly

in a way these extensions are infecting the layout scripts of HTTPS pop-up windows.
HTTPS vs. HTTP matters because HTTPS adds even more to the statusbar, which then widens the window beyond what you can see, which will have unfortunate effects on layout.

*** This bug has been marked as a duplicate of 204743 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 204743 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.