CSS-based image-list ("gallery") frequently rendered differently on repeated reload

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
9 years ago

People

(Reporter: franz.gans, Unassigned)

Tracking

1.8 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(7 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.7.12) Gecko/20050920 Firefox/1.0.7

A CSS- and unordered-list-based gallery is rendered differenty when it
is repeatedly reloaded.

Affected are Linux Versions 1.0.8 and 1.5.0.4 of FF.
(Opera 8.02 show frequently errors, but Konqueror 3.4.0 works OK).

cf. screenshots.

Reproducible: Always

Steps to Reproduce:
1. place files on web-server (not on local HD)
2. open URL in FF
3. search rendered page by scrolling thru
4. reload by pressin Shift-Ctrl-R and Ctrl-R
5. repeat 3.

Actual Results:  
There a three different types of errors:
1. When reloading the page with Shift-Ctrl-R none or only few images
   are rendered (case1.jpg)
2. When reloading the page with Shift-R all or only few images
   are not rendered
3. The results vary from reload to reload.

Expected Results:  
1. FF shall produce the same output every time the same input
   is rendered and FF's "initial state" is the same.
   FF shall not have different "initial state" after loading
   the same source multiply.
2. FF shall render the page correctly.


I found the CSS-gallery on
http://www.brunildo.org/test/ImgThumbIBL2b.html
where I could NOT find any rendering quirks.
(Reporter)

Comment 1

12 years ago
Created attachment 225730 [details]
Expected result
(Reporter)

Comment 2

12 years ago
Created attachment 225731 [details]
One div-element is rendered wron after SHIFT-R
(Reporter)

Comment 3

12 years ago
Created attachment 225732 [details]
Every div seems to be rendered incorrecty, but ...
(Reporter)

Comment 4

12 years ago
Created attachment 225734 [details]
... if you scroll down, you'll find one that's OK
(Reporter)

Updated

12 years ago
Attachment #225732 - Attachment description: Seems to be rendered correcty, but ... → Every div seems to be rendered incorrecty, but ...
(Reporter)

Updated

12 years ago
Attachment #225734 - Attachment description: ... if you scroll down, youl see a missing div → ... if you scroll down, you'll find one that's OK
(Reporter)

Comment 5

12 years ago
Created attachment 225735 [details]
SOURCE: place this on webserver
(Reporter)

Comment 6

12 years ago
Created attachment 225736 [details]
SOURCE: place this preview image on webserver
(Reporter)

Comment 7

12 years ago
Created attachment 225737 [details]
SOURCE: place this background image on webserver
Component: General → Layout: Block and Inline
Product: Firefox → Core
QA Contact: general → layout.block-and-inline
Version: unspecified → 1.8 Branch
(Reporter)

Comment 8

9 years ago
FF 3.0.15 and FF 3.5.5 work OK
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Thanks for letting us know that it's fixed.

When we don't know what fixed the problem, we use the WORKSFORME resolution rather than FIXED, though.
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.