recursive innerHTML makes the browser unresponsive

RESOLVED DUPLICATE of bug 197052

Status

()

RESOLVED DUPLICATE of bug 197052
13 years ago
13 years ago

People

(Reporter: pallosp, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2

The browser doesn't interrupt the following script after a period of time. The user interface becomes unresponsive.

<html>
dummy
<script>
document.write(document.getElementsByTagName("html")[0].innerHTML);
</script>
</html>


Reproducible: Always
(Reporter)

Comment 1

13 years ago
Related issue:

The following code uses 512 MB ram before it gets stopped. I think lower memory limit should be allowed for scripts.

<script>
x=' ';
for (i=0; i<100; i++) x+=x;
document.write(x);
</script>

Comment 2

13 years ago
==> DOM
Assignee: general → general
Component: General → DOM
Product: Mozilla Application Suite → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch

*** This bug has been marked as a duplicate of 197052 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.