If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

do not show branded icon by default, use smaller branded icons for wizard, only show it for certain scenarios

RESOLVED FIXED in Firefox 2 beta2

Status

()

Firefox
General
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug, {fixed1.8.1, regression})

2.0 Branch
Firefox 2 beta2
fixed1.8.1, regression
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mustfix])

Attachments

(20 attachments, 5 obsolete attachments)

115.67 KB, image/png
Details
17.11 KB, image/png
Details
24.12 KB, image/png
Details
31.63 KB, image/png
Details
32.01 KB, image/png
Details
3.97 KB, image/png
Details
3.32 KB, image/png
Details
2.92 KB, image/png
Details
4.56 KB, image/png
Details
4.07 KB, image/png
Details
51.01 KB, image/tiff
Details
263.00 KB, image/tiff
Details
185.04 KB, image/tiff
Details
134.17 KB, image/tiff
Details
124.03 KB, image/tiff
Details
5.28 KB, patch
rstrong
: review+
mconnor
: approval1.8.1+
Details | Diff | Splinter Review
27.62 KB, image/png
Details
31.73 KB, image/png
Details
25.99 KB, image/png
Details
20.86 KB, image/png
Details
use smaller branded icons for wizard.

spun off from bug #339526.  see nick's comments and ben's comments about the size of the icon (64x64) in the wizard.

ben suggests:  use a smaller icon (32x32 instead of 64x64) unless there is a "byline"), and if so, use a 16x16 icon.  

(note to be, about the 16x16, that seems really small to me.  isn't that the size of a window icon?)

beltzner, what do you think?


the branded 64x64 icon that steven created (for bonecho and minefield) still has value, as it is used on the mac for alerts.

steven, how much work would it be to create 32x32 verisons of the icons for both the official firefox brand, bonecho and minefield?
Anyone have a screenshot of what this dialog looked like bfore it had the icon? Also, is it necessary that all wizards use an icon (and use the same icon)?
Created attachment 225878 [details]
Before & after for Create Profile, Software Update and Import wizards
It is definatly not necessary that all wizards use an icon. In particular I use wizards in at least one of my extensions and I don't want an icon there.
> It is definatly not necessary that all wizards use an icon.

Good point.  Mike / Ben, what do you think? 
Status: NEW → ASSIGNED
Ideally there would be an attribute that someone could set: off, use default, use specified. 
updating summary.  details (from beltzner) coming soon.
Flags: blocking-firefox2?
Summary: use smaller branded icons for wizard → not show branded icon by default, use smaller branded icons for wizard, only show it for certain scenarios
I think the caller of the dialog should be able to specify between no icon, default product icon, and specific wizard icon. 

IIRC, the purpose for having the icon was that in the install-and-migrate scenario, the import settings wizard would appear before Firefox, leading to some confusion about who owned the window, and where it came from. I think that's the usage heuristic that should be applied for wizard icons: when it would be otherwise impossible to determine where a window came from, we should provide some indication to the user about its predigree. So the only other wizard(s) that I can see requiring it would be the Profile Manager and Michael Wu's new extension-update-check dialog. 

But the giving the ability to XUL authors to turn it on as they see fit seems like the right thing to do. 

Ben? Sound sensible?

Updated

11 years ago
Flags: blocking-firefox2? → blocking-firefox2+
Whiteboard: swag: .5d
Target Milestone: --- → Firefox 2 beta1
patch in hand, at least for the "do not show by default".

robert suggests a specific size for the wizard (39 or 37 pixels?)  I'll double check with him before requesting new icons from steven.
Summary: not show branded icon by default, use smaller branded icons for wizard, only show it for certain scenarios → do not show branded icon by default, use smaller branded icons for wizard, only show it for certain scenarios
> patch in hand, at least for the "do not show by default". 

oops, my patch is not working.
Created attachment 227196 [details] [diff] [review]
patch to only show branding icon when brand="true" is set on the wizard (and only set it for import)
Hardware: Macintosh → All
Created attachment 227199 [details] [diff] [review]
patch for trunk, includes new icon49.png from robert
Attachment #227196 - Attachment is obsolete: true
Created attachment 227200 [details]
screen shot
I'll do a comparison of our wizard with other win32 wizards to verify it matches appropriately.
> I'll do a comparison of our wizard with other win32 wizards to verify it
> matches appropriately.

robert, I would appreciate it if you kept your bugzilla comments to a minimum.
Created attachment 227201 [details]
screen shot of profile wizard, showing how it is off by default now
(In reply to comment #14)
> robert, I would appreciate it if you kept your bugzilla comments to a minimum.
Yes SIR! or do you prefer that I address you as SIR SETH?

*oh darn... I hope my replying to the grand exalted one who has children that need to be saved and for some odd reason denies their existence doesn't get upset over my replying to him when he wants me to keep my bug comments to a minimum*
Created attachment 227202 [details] [diff] [review]
patch including official branding changes
Attachment #227199 - Attachment is obsolete: true
Attachment #227202 - Flags: review?(robert.bugzilla)
Whiteboard: swag: .5d → [SWAG: patch in hand, seeking reviews]
Created attachment 227204 [details]
screenshot comparison

I don't have a problem with the height and width of our wizard (I actually prefer it in that it differentiates the app from standard OS wizards) but I do think the header in our wizard is too tall especially since we usually - perhaps always? - don't provide a sub-section header text in our headers.
Created attachment 227205 [details]
screenshot comparison with a minor css change to winstripe

This screenshot was made with the following changes to the wizard.css for winstripe.

.wizard-header {
   border-bottom: 2px groove ThreeDFace;
-  padding: 10px 0px 10px 0px;
   background-color: Window;
   color: WindowText;
 }

+.wizard-header-box-text {
+  padding: 10px 0px 10px 0px;
+}
+
Comment on attachment 227202 [details] [diff] [review]
patch including official branding changes

Clearing review for now... I am fine with this overall with the added styling for winstripe but I'd like to see how this looks on Mac OS X and Linux first... I've found that we sometimes look significantly different on Linux and no one bothers reporting bugs on it.

btw: it goes against the grain to have an image that is 49px by 49px. I think it best to just use 48px for them.
Attachment #227202 - Flags: review?(robert.bugzilla)
> Clearing review for now... I am fine with this overall with the added styling
> for winstripe but I'd like to see how this looks on Mac OS X and Linux first...
> I've found that we sometimes look significantly different on Linux and no one
> bothers reporting bugs on it.

good point.  I also agree with you on using 48px.  here's my new todo list:

1) create 48x48 images (icon48.png) for bonecho, minefield and official branding
2) test out robert's suggest css improvement
3) get some screen shots on windows, mac and linux
4) seek review
I can provide the 48px images. We already have them for the branded version and trunk version as 48px is one of the default sizes for WinXP icons. Will post here shortly.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Created attachment 227249 [details]
48px branded icon
Created attachment 227250 [details]
48px trunk icon
Created attachment 227252 [details]
48px branch icon
Comment on attachment 227202 [details] [diff] [review]
patch including official branding changes

working on a new patch using robert's css, the 48x48 icon (thanks steven!)
Attachment #227202 - Attachment is obsolete: true

Updated

11 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Created attachment 227261 [details]
48px sunbird icon
Created attachment 227262 [details]
48px thunderbird icon
Whiteboard: [SWAG: patch in hand, seeking reviews] → [SWAG: .25 days]
Status: REOPENED → ASSIGNED
Created attachment 227297 [details]
screen shot on the mac
Created attachment 227298 [details] [diff] [review]
patch (does not include robert's css change)
Created attachment 227299 [details] [diff] [review]
patch with robert's suggested css fix
Attachment #227298 - Attachment is obsolete: true

Updated

11 years ago
Target Milestone: Firefox 2 beta1 → Firefox 2 beta2
Blocks: 339526
Blocks: 343819
Blocks: 343820
*** Bug 344555 has been marked as a duplicate of this bug. ***
Whiteboard: [SWAG: .25 days] → [SWAG: .25 days] [mustfix]
robert asked me to check some mac applications to see if their wizards are branded or not.  

my conclusion is that for wizards, they are branded, but not always the same way.

let me attach some screen shots.

so for this bug I think we should brand for all platforms, but then open a new bug on mac os x to brand more like how apple mail, airport setup assistant, and migration assistant are branded.

cc'ing pink, mark and josh who have forgotten more about standard mac application UI then I'll ever know. 
Created attachment 230009 [details]
airport setup wizard (standard mac wizard look?)
Created attachment 230010 [details]
mail.app import (standard mac wizard look?)
Created attachment 230011 [details]
migration assistant wizard (standard mac wizard look?)
Created attachment 230012 [details]
ical import (non-standard, but closes to fb/tb import branded wizard)
Created attachment 230088 [details] [diff] [review]
patch

patch, here comes a screen shot from win32
Attachment #227299 - Attachment is obsolete: true
Attachment #230088 - Flags: review?(robert.bugzilla)
Created attachment 230089 [details]
screen shot of minefield side-by-side with network setup wizard
seeking review.  note, I've landed the icons on trunk and branch, as they already have ui review
Whiteboard: [SWAG: .25 days] [mustfix] → [mustfix][fix in hand seeking review]
Created attachment 230095 [details]
screen shot from bonecho with official branding
Created attachment 230097 [details]
non branded wizard screen shot
Attachment #230088 - Flags: review?(robert.bugzilla) → review+

Comment 43

11 years ago
They're not called wizards on the Mac, they're called assistants.  (I always thought that calling them wizards was pretty lame.)

The standard Mac appearance is roughly as the screen shots Seth posted depict, but assistants aren't used too frequently on the Mac.  The appearance particulars aren't so well-specified other than that "it should look sort of like this."

http://developer.apple.com/documentation/UserExperience/Conceptual/OSXHIGuidelines/XHIGInstallationsUpdates/chapter_9_section_4.html
thanks for the info and the link, mark.

I'm going to land what I've got, but log a spin of bug about "make wizards on the mac look more like the typical "assistant" dialogs.
fix landed on trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Keywords: regression
Resolution: --- → FIXED
Whiteboard: [mustfix][fix in hand seeking review] → [mustfix][fixed on trunk]
Comment on attachment 230088 [details] [diff] [review]
patch

seeking a= for branch
Attachment #230088 - Flags: approval1.8.1?
Blocks: 345467
> I'm going to land what I've got, but log a spin of bug about "make wizards on
> the mac look more like the typical "assistant" dialogs.

see bug #345467
Blocks: 345468
see bugs #345467 and #345468 to check in icon48.png (and add branded=true) for tbird and sunbird.
Created attachment 230132 [details]
branded import wizard from minefield
Comment on attachment 230088 [details] [diff] [review]
patch

a=mconnor on behalf of drivers for checkin to the 1.8 branch
Attachment #230088 - Flags: approval1.8.1? → approval1.8.1+
fixed on branch.
Keywords: fixed1.8.1
Whiteboard: [mustfix][fixed on trunk] → [mustfix]
You need to log in before you can comment on or make changes to this bug.