Last Comment Bug 341732 - Making a Firefox windows installer needs to be described better
: Making a Firefox windows installer needs to be described better
Status: RESOLVED FIXED
:
Product: Developer Documentation
Classification: Other
Component: General (show other bugs)
: unspecified
: x86 Windows XP
: -- enhancement (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
http://developer.mozilla.org/en/docs/...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-16 03:24 PDT by Bengt-Erik Soderstrom
Modified: 2012-12-28 16:06 PST (History)
7 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Bengt-Erik Soderstrom 2006-06-16 03:24:13 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060616 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060616 Minefield/3.0a1

With bug 340864 I think it is important that the build & install documentation is updated: There is a need to install NSIS (http://nsis.sourceforge.net) and also make sure it is in the path. Also 7-Zip and UPX must be installed and in the path.
The resulting self-extracting archive will be found in ../dist/install/sea

Doing this, make -C objdir/browser/installer installer will work fine again...
 



Reproducible: Always
Comment 1 Ryan Flint [:rflint] (ping via IRC for reviews) 2006-06-16 15:41:52 PDT
You know, it is a wiki ;)
Comment 2 Eric Shepherd [:sheppy] 2007-01-02 11:47:44 PST
Could someone who actually knows how to do this write something up? :)
Comment 3 Jeff Walden [:Waldo] (remove +bmo to email) 2007-01-02 22:20:09 PST
> Could someone who actually knows how to do this write something up? :)

It takes a little work, but Windows tinderboxen logs contain the necessary commands; explanation beyond the commands themselves is probably still best left to someone who's done it before.
Comment 4 Myk Melez [:myk] [@mykmelez] 2007-09-20 13:18:48 PDT
> With bug 340864 I think it is important that the build & install documentation
> is updated: There is a need to install NSIS (http://nsis.sourceforge.net) and
> also make sure it is in the path. Also 7-Zip and UPX must be installed and in
> the path.

Most of this info is already in the doc (perhaps added by someone who wasn't aware of this bug), but I added info about NSIS and made the info about 7-Zip and UPX clearer.


> The resulting self-extracting archive will be found in ../dist/install/sea

I've added this to the doc.
Comment 5 Myk Melez [:myk] [@mykmelez] 2007-09-20 13:41:32 PDT
Note: per bsmedberg on IRC, I've since moved the Cygwin-related stuff to:

http://developer.mozilla.org/en/docs/Windows_build_prerequisites_using_cygwin

Note You need to log in before you can comment on or make changes to this bug.