Closed Bug 341844 Opened 15 years ago Closed 15 years ago

Attempting to launch FireFox while updating through the automatic downloader/updater causes a crash and update errors

Categories

(Toolkit :: Application Update, defect)

1.8 Branch
x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: runningferret, Unassigned)

References

Details

(Keywords: fixed1.8.1, Whiteboard: [fixed by bug 312010])

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.3

Auto-downloaded 1.5.0.4, and the dialog prompted to update from 1.5.0.3.  Choose update now.  While the update was being applied, I launched FireFox again.  An error popped up, the installer crashed, and a new installer prompting me to install the (null) version of FireFox popped up.  Subsequent update searches find no new software(possibly due to how far the install actually got).  The "FireFox has been updated!" page was shown when I opened FireFox after the crash, though About still tells me I have 1.5.0.3

Reproducible: Didn't try

Steps to Reproduce:
1.Install 1.5.0.3
2.Wait for autodownload of 1.5.0.4 patch
3.Apply patch immedately.
4.While patch is installing, attempt to open FireFox again

Actual Results:  
Installer crashed and FireFox did not update.  FireFox cannot find updates, as it thinks the 1.5.0.4 patch successfuly installed when it did not.

Expected Results:  
Error and say that FireFox cannot be opened while a patch is installing.
Can you go to help - about and see what version is listed there. You build identifier is a bit strange, everything except the Firefox/1.5.0.3 suggests that you are running Firefox 1.5.0.4.
The text directly below "Firefox" is:
version 1.5.0.3.
The long string at the bottom is:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.3
Fixed by bug 312010.
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [fixed by bug 312010]
Version: unspecified → 2.0 Branch
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.