IMAP doesn't see my mail folders in IMAP server directory

VERIFIED FIXED in M17

Status

MailNews Core
Backend
P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Tony DeJoie, Assigned: jefft)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (Win98; U)
BuildID:    2000233116

IMAP server directory: /u/tony/MailBox/Sift - in this directory I have multiple 
mailboxes and subdirectories containing more mailboxes. In "server-advanced" -- 
Show only subscribed folders and Server supports only... always revert to the 
selected state. I need them off. Since they were selected I tried subscribing to 
my mail folders, but File->subscribe only presents me with newsgroups. If I 
manualy create a .mailboxlist on the mail server side - then I see my mailboxes 
in a flat space (ie all subdirectory mailboxes show up at top level in the mail 
folder list) 

Reproducible: Always
Steps to Reproduce:
I think the description above describes everything needed to reproduce the 
problem

Expected Results:  I expected Mozilla IMAP mail to behave exactly like Netscape 
4.72 which I am currently using for email. (Note I've used Netscape 4.08 thru 
the current release with the same IMAP setup without troubles)

I expected to see in the mail folder list all my mail folders and subdirectories 
containing mail folders.

/u/tony is my UNIX home directory. The IMAP server is a Solaris 7 server running 
WU IMAP:

telnet ice 143
Connected to ice.
Escape character is '^]'.
* OK ice IMAP4rev1 v12.264 server ready

Comment 1

18 years ago
cc: bienvenu. 

QA Contact: lchiang → huang

Comment 2

18 years ago
Cc: Jefft
Jeff, do you think this is dup of bug#28181 which we tried to investigate 
before?
(Reporter)

Comment 3

18 years ago
Created attachment 7199 [details]
Mozilla vs 4.72 view of IMAP folders
(Reporter)

Comment 4

18 years ago
The image I sent was created by using 4.72 to subscribe to my mail folders, then 
running Mozilla. Mozilla currently doesn't run with "Show only subscribed 
folders" unselected -- it always reverts back to the selected state (perhaps I 
should have put this in a seperate bug report?)

Comment 5

18 years ago
Thanks. That will be more helpful!
Jeff, I believe that I logged a bug regrading to IMAP server directory for 5.0 
before, I will try to find that bug!!

Comment 6

18 years ago
There was bug#28089 related to this bug, but it's not exactly the same.
I am thinking if fix for bug#28089 will fix for this bug too....
(Reporter)

Comment 7

18 years ago
bug#28089 sounds similar - I expect that a .mailboxlist file is not required if
"show only subscribed folders" is unselected - this is the way I use
netscapeV4.72 and other IMAP capable mail clients (such as pine, eudora and
outlook)

Comment 8

18 years ago
Jeff - do you get this bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 9

18 years ago
I'll take it.
Assignee: selmer → jefft
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 10

18 years ago
Tony, can you try today's build and see if the build fixes your problem? I 
checked in a fix for bug 20878 which should fix your problem too. I am marking 
this one fixed. Please reopen it if the problem still exists.
(Reporter)

Comment 11

18 years ago
This should be reopened.

I tried Build 2000050908 and the folder view is now correct (bug#28181).

But without a .mailboxlist file and "subscribe" unchecked in advanced prefs I
still cannot see any folders.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 12

18 years ago
Yes. That's why we still have some issues need to investigate on bug 20879

Comment 13

18 years ago
Tony, are you retesting on the migrated profile or new profile?
I know that if I testing on the migrated profile, it's working.
Bbut if I created new profile, I saw some strang on the folders pane....
Jeff, is this bug can only be tested on the migrated profile?
(Reporter)

Comment 14

18 years ago
Karen, I tried both ways (migrated and new profile). In Netscape 4.5+ the
.mailboxlist file is only referenced when "Show only subscribed folders" is
selected. When its not selected Netscape4.5+ finds all the folders in the server
directory by itself. From what I see Mozilla can not find any mail folders in
the absense of a .mailboxlist file. Mozilla seems to be operating in a
"subscribed" mode only.
(Assignee)

Comment 15

18 years ago
Tony, you are right if not using subscription we should list all folders.
Status: REOPENED → ASSIGNED
(Reporter)

Comment 16

18 years ago
Jeff, thanks for your concensus.  BTW - Can I assume the subscribe functionality
is not implemented yet for IMAP mail, or part of another bug?

Comment 17

18 years ago
I am thinking that we should address the issue to other IMAP subscribe bug...
(Assignee)

Comment 18

18 years ago
The subscribe ui is there but not hooked up for imap server. I'll check with 
sspitzer for how to hook it up.

Comment 19

18 years ago
bug 17795 is the feature bug: subscribe dialog for IMAP....still not implement 
yet....

Comment 20

18 years ago
Seth, can we dup this against one of your bugs?  Since we're doing IMAP 
subscribe, this bug should just go away.

Comment 21

18 years ago
Based on Jeff & Tony's comments and my verifications on bug 20878, bug 28181.
I think this bug already been fixed.
bug 17795 is for the IMAP subscribe folders UI implement.
I already logged 38943 for tracking "If Mozilla not using subscription -- should 
list all folders problem."

I think Jeff can mark as fixed for this bug now.
Please address not using subscription problem on bug 38943. Thanks.
(Reporter)

Comment 22

18 years ago
I'll agree that bug#38943 describes the remaining problem I have with IMAP mail.

(Not sure where to ask this, but will there be a new Solaris build soon?)

Comment 23

18 years ago
You may post this question on newsgroup for asking this question.
Or Lisa, can you answer Tony's question?

Comment 24

18 years ago
Jeff, if you agree for addressing "not using subscription problem" on bug 38943. 
Please mark this bug  as fixed, so I can verify this bug then.

Comment 25

18 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17
(Assignee)

Comment 26

18 years ago
Mark as fixed. The rest of the problem is addressed by the other bug.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 27

18 years ago
Marking verified based on Jeff, Tony comments & bug 20878 verification.
Status: RESOLVED → VERIFIED

Comment 28

18 years ago
tony - not sure about Solaris builds.  You may want to ask in builds newsgroup. 
Thanks.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.