multi-level coloring when displaying quoted messages

RESOLVED DUPLICATE of bug 851022

Status

Thunderbird
Mail Window Front End
--
enhancement
RESOLVED DUPLICATE of bug 851022
12 years ago
5 years ago

People

(Reporter: Vladimir Kotal, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.0.3) Gecko/20060602 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (X11; U; SunOS i86pc; en-US; rv:1.8.0.3) Gecko/20060602 Firefox/1.5.0.3

when replying to or displaying messages with multiple levels of replies, it would be user-friendly if every level will have different color. this is done e.g. in mutt. it should be also configurable.

Reproducible: Always

Steps to Reproduce:
1. display message with multiple levels of replies

Actual Results:  
same color is used for all levels of replies

Expected Results:  
different colors should be used - for each level one color

for example the following e-mail excerpt would have two colors:

>> I have started writing the paper. Could you 
>> look at enclosed draft and tell me if it is ok ?
> 
> No problem.

this is should be applied to both plain text and HTML-formatted messages.

Comment 1

12 years ago
Duplicate of bug 219344/bug 300810 -> Suite bug 90315?

Comment 2

12 years ago
For viewing only (not composition) see the Quote Colors extension -- http://quotecolors.mozdev.org/ -- does the job nicely.
(Reporter)

Comment 3

12 years ago
Quote Colors is really cool, thanks for the link. To have something for composition and I will be happy.

Comment 4

12 years ago
So will I be! :)

I've submitted an RFE here -- https://bugzilla.mozilla.org/show_bug.cgi?id=368454 -- you may wish to track this in case Mozilla or a third party implement this. The developer of Quote Colors, for whatever reason, is somewhat sceptical that it can be done in an extension at all, so it may be down to Mozilla to implement. I don't know.
QA Contact: front-end

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90315

Comment 6

5 years ago
Reduping for Thunderbird's version of that issue.
Duplicate of bug: 851022
You need to log in before you can comment on or make changes to this bug.