Accessibility -- use real <table> for summary of changes

RESOLVED DUPLICATE of bug 65477

Status

()

defect
RESOLVED DUPLICATE of bug 65477
13 years ago
13 years ago

People

(Reporter: aaronlev, Unassigned)

Tracking

({access})

Details

As screen reader users become more involved in FOSS, we need to ensure that tools such as Bugzilla are accessible.

The email notifications are not accessible with a screen reader, because of the simulated tables via Ascii. It's a real problem -- a screen reader recently asked me about a bugmail because he had no way to understand it in text to speech.

For example, the following would be accessible to a screen reader user if it was rendered as an HTML table:

           What    |Removed                     |Added
----------------------------------------------------------------------------
            Summary|Please add sound events to  |Add sound events to
Firefox.
                   |FireFox.                    |

In this format, the text is read line by line from left to right, and makes no sense at all.
Having an option for bugmail using HTML was already reported. Perhaps it should do both text/plain + text/html as default, but that is for the other bug.

*** This bug has been marked as a duplicate of 65477 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.