High (up to 100%) cpu usage on <wetter.rtl.de> URL, Flash involved

RESOLVED INCOMPLETE

Status

()

--
major
RESOLVED INCOMPLETE
13 years ago
10 years ago

People

(Reporter: mailbox, Unassigned)

Tracking

({perf})

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060616 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060616 BonEcho/2.0a3

I just went to http://wetter.rtl.de/deutschland/uebersicht.php?id=10708&id2=10708&ort=Saarbr%FCcken and always have 100% cpu usage... page is very slow and almost unusable for me ...

can somebody of you look on it ?

I can reproduce it everytime.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060616 BonEcho/2.0a3 ID:2006061603

Console² 0.3.5
DOM Inspector 1.8.1a3 [DISABLED]
Flashblock 1.3.4
Image Zoom 0.2.6
JavaScript Options 1.2.4 [DISABLED]
Nightly Tester Tools 1.0.4
Password Save [de] 0.5
Popup Count 0.3.4
Talkback 2.0a3
Update Channel Selector 1.0.1

-------------

Two optinions from forum

AteUte52 wrotes:
WFM, only 15% CPU and looks normal to me?

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060618 BonEcho/2.0a3 ID:2006061804

----------
Rigido wrotes:
146MB and near 50% CPU usage just having two tabs (mozillaZine forum and wetter.rtl.de site). Closing wetter tab and opening a new one CPU usage drops to 10%
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060618 BonEcho/2.0a3 ID:2006061804

Reproducible: Always
(Reporter)

Comment 1

13 years ago
I found out that Flash causes that trouble.

That flash-newsticker on the left side of the "powered by RTL" logo causes 50% CPU usage.
Each other Flash animation need about 5% ...  

So, overall this causes 100% CPU 


I use Flash 8.0 r24
(Reporter)

Comment 2

13 years ago
Now I use newest flash  9.0 r16,  but problem is still there
Version: unspecified → 2.0 Branch
I'm currently getting 22% with a minefield build. Performance and memory consumption should have improved since the checkin of bug 342810.

Marking as duplicate of bug 377419 - Flash performance problems.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377419
Jim,
this bug can't be a duplicate of bug 377419, which occured on Trunk in november/december 2006 only. (and that/my bug does not occur on branch(es).)

(May be some other Flash related bug ?)

If you think there could be a common cause/fix, I suggest to mark them dependent for now. (or, if there isn't one, to create a meta "Flash perf." bug.)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I'm not sure I follow you - memory consumption problems have been fixed on trunk via bug 342810, which was a trunk only bug. CPU consumption for this site and for the site on bug 377419 are moderately high for both trunk and past branches, which seem to indicate they are the same issue. Are you saying this is a bon echo branch bug only which isn't in trunk?  or vice cersa?
(In reply to comment #5)

(Sorry, I didn't see your comment before, as I was not in the CC list of this bug :-|)

> I'm not sure I follow you - memory consumption problems have been fixed on
> trunk via bug 342810, which was a trunk only bug. CPU consumption for this site

(Right, the current bug is not about memory consumption: cpu usage only.)

> and for the site on bug 377419 are moderately high for both trunk and past
> branches, which seem to indicate they are the same issue. Are you saying this

No, see bug 377419 comment 8 for cpu usage figures (for that bug):
bug 377419 is Trunk (= Gecko 1.9) only.

> is a bon echo branch bug only which isn't in trunk?  or vice cersa?

I'm not saying that this bug is either Trunk/branch specific:
I'm saying that, based on (older) date and version of this bug report, this is a different (maybe underlying ?) bug than bug 377419 (case).

*****

(In reply to comment #0)
> I can reproduce it everytime.

I tried to reproduce with FFv2/v3 and SMv1.0/v1.1/v2.0:

1) The figures I got looked like bug 377419 indeed: my cpu going from 05-15% on branches to 15-25% on Trunk only.
2) It seemed getting the bug on Trunk depended on which (Flash) adds showed up :-/ (This would need a more reliable testcase...)

Reporter,
*can you give a regression timeframe for your initial report ?
*can you check with current releases/nighlies ?

Marking bug as depending on bug 377419 for the time being...
Depends on: 377419
Summary: always 100% cpu usage on http://wetter.rtl.de/deutschland/uebersicht.php?id=10708&id2=10708&ort=Saarbr%FCcken → High (up to 100%) cpu usage on <wetter.rtl.de> URL, Flash involved
install flashblock extension and you see the cpu goes away, so this is entirely (or mostly) related to flash.  16 flash images, each one for me contributes ~1% to cpu load.  Hide the tab and cpu usage drops to ~5% -- but not to zero which is what one would want.  Reduce number of images on screen by scrolling and cpu is reduced.

Shockwave Flash 9.0 r47. same results with
* Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b2pre) Gecko/2007110805 Minefield/3.0b2pre
* Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070530 Minefield/3.0a5pre 
* Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a5pre) Gecko/20070529 Minefield/3.0a5pre 

the last one works great for bug 377419's reduced testecase, so this bug probably not related to 377419 (plus this bug doesn't involve iframe, but 377419  does)
No longer depends on: 377419
Restoring "Depends on : 377419" for the time being;
as the "iframe" issue proved to be bug 397303 and not bug 377419.

To have a regression timeframe would still be great...
Depends on: 377419
Andreas, do you see this problem with current beta of 3.1 and flash v10?
 http://www.mozilla.com/en-US/firefox/all-beta.html

I don't see a problem. ~10% CPU when using 3.1b4pre
Keywords: perf, regressionwindow-wanted
1.)
i get no (very) high usage of CPE time using
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.20) Gecko/20081217 Firefox/2.0.0.20 ID:2008121709
+
flash (NPSWF32.dll) version 10.0.22.87

2.)
there's no flash-newsticker on the left side anymore, so there's a lacking testcase

=> can keyword "regressionwindow-wanted" be removed & this bug closed incomplete?

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago10 years ago
Resolution: --- → INCOMPLETE
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.