No error is displayed if you cannot connect

VERIFIED DUPLICATE of bug 37991

Status

()

Core
Networking
P3
normal
VERIFIED DUPLICATE of bug 37991
19 years ago
18 years ago

People

(Reporter: Stephen Rasku, Assigned: Sammy Ford)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you try and connect to a site that isn't running a web-server it will just
retain the old display and display "Document: Done (x.yyy secs)".  It should
display an error message.  I am running Linux M14 which I compiled myself.
mozilla/CVS/Tag is "TSeaMonkey_M14_no_crypto_RELEASE".
(Reporter)

Comment 1

19 years ago
*** Bug 34212 has been marked as a duplicate of this bug. ***

Comment 2

19 years ago
reporter - since you are using m14, this is invalid. M15 builds have a pop-up
that tells you the site does not exist:

"www.whatever.com could not be found. Please check the name and try again."

if you get a m15 build (carefull, the latest ones have some bad regressions),
and still see no error message, reopen please.

thank you
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
yup verifed invalid agreeded
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

18 years ago
I just tested this with "Mozilla/5.0 (X11; U; Linux 2.2.5-15 i686; en-US; m15)"
and I saw no such error message.

Why can't I reopen this bug?

Comment 5

18 years ago
If I go to http://www.mozillla.org, a invalid address, I get an error with the 
newest m16 nightly.
(Reporter)

Comment 6

18 years ago
That is not quite the same issue.  You are trying to connect to a site that
isn't even in DNS.  Using the latest nightly build and trying to connect to
http://www.mozillla.org/, I got the same results that you did.  However, trying
to connect to http://tgivan.com/, a site that exists but that isn't running a
web server, and all I get is:

	Document: Done (0.374 secs)

Using Netscape 4.72, I get:

	Netscape's network connection was refused by the server tgivan.com
	The server may not be accepting cnnections or may be busy.

	Try connecting again later.

Mozilla should give an equivalent error message.

Comment 7

18 years ago
OK, I'm reopening this and sending it to Networking.  
Component: Browser-General → Networking

Comment 8

18 years ago
oops, re-open
Status: VERIFIED → UNCONFIRMED
Resolution: INVALID → ---

Comment 9

18 years ago
well, I just tested this with 042008 build under NT and I get "A connection was 
refused when attempting to contact tgivan.com" dialog.  This is worksforme. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → WORKSFORME
verifying bug.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 11

18 years ago
My tests were done under Linux.  Does it work under that?  It didn't for the 
latest build I used.

Comment 12

18 years ago
i came across this from the bug on bugzilla where people can't reopen
bugs they reported. It looks like this linux bug was verified on
win32, not on linux. Sford, could you check this out please? Or stephen,
if you're not having the problem any more could you make a note?
Status: VERIFIED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 13

18 years ago
assigning to sford to verify this on linux.
Assignee: cbegle → sford3
(Reporter)

Comment 14

18 years ago
Since I couldn't reopen this, I ended up creating a new bug.

*** This bug has been marked as a duplicate of 37991 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 15

18 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.