Closed Bug 342140 Opened 15 years ago Closed 15 years ago

auto search (when you type in a page and it automaticaly resolve as search on the page) feature sometime makes the browser impossible to write in box form

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 339465

People

(Reporter: alexandre0984, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4 Creative ZENcast v1.00.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4 Creative ZENcast v1.00.12

See sumary

Reproducible: Always

Steps to Reproduce:
1. (this isn't always repoducible, I don't know how to do it...) When on a webpage with text, I try to type. It will result in a search on the page
2. There is 2 possibilities :
a: it works. Search go through (95% of the time)
b: search works, but i'm unable to type inside a box form.
3. If 2a happens, then I go in options/advanced then I unclick case about auto search... (don't have the real name because I use Firefox in French) and reactivate it and it works back.

Actual Results:  
See steps

Expected Results:  
See steps

This bug is weard... I really don't understand what creates it. The only thing I can say is that it happen since (at least) Firefox 1.5.0.2
Component: Keyboard Navigation → Find Toolbar / FastFind
QA Contact: keyboard.navigation → fast.find
Whiteboard: DUPEME
I've been seeing this problem for a while now, since ~1.5 I think, and it is definitely still present in 1.5.0.5.

I see the problem on two different PCs on a regular basis (every day or two). The only plugins that are common between the PCs are Web Developer and DOM Inspector. Both PCs have "Begin finding when you begin typing" enabled.

To clarify what happens:

I have Google as my homepage. I'll often start up a FireFox instance and just expect to be able to start typing to perform a Google search. 99% of the time this works fine, however on occassion FireFox instead performs a find/highlight for text on the page instead. Once this happens, I cannot get the focus to "stick" back in the Google search text input form. The cursor will blink if I click there, but whenever I start typing FireFox performs a find/highlight again.

To resolve, I have to either close down all open instances of FireFox and restart it, or go into advanced settings and disable then reenable the "Begin finding..." option.
Maybe you're seeing bug 339465 here?
Blocks: findgrabs
You're right, this looks like a dupe.

(In reply to comment #2)
> Maybe you're seeing bug 339465 here?


*** This bug has been marked as a duplicate of 339465 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.