Drag&drop-hovered bookmark folder icon is smaller than the normal one - item shift (drag & drop behaves erratic when hovering over folder on bookmark toolbar)

RESOLVED FIXED

Status

()

P4
minor
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: dennisml, Unassigned)

Tracking

({polish})

Trunk
x86
Linux
polish
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060616 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060616 Minefield/3.0a1

When I try to drag&drop a page into a folder on the bookmark toolbar and hover over the folder all elements to the right of it get shifted to the left a few pixels. The real problem however is that when you hover near the left or right margin of the folder this shifting causes the following:

1. Folder goes into hover state
2. The shifting apparently causes the bounding box to change so the cursor now ends up outside of that bounding box.
3. Folder goes into regular state
4. Since the elements shift back to their "normal" position the cursor ends up back inside the bounding box.
5. Continue at 1


Reproducible: Always
(Reporter)

Updated

12 years ago
Version: unspecified → Trunk
Component: Bookmarks → Places
QA Contact: bookmarks → places

Comment 1

12 years ago
This WFM with Minefield on Windows from 20061107. 

reporter do you have any extensions installed? if so please attempt to reproduce in Safe Mode
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

11 years ago
This problem still exists but this time entries to the right of the hovered item shift to the left.

The problem is that the hovered folder icon (folder with blue arrow) is smaller than the regular folder icon so when the image changes on hovering the entry gets smaller leading all elements to the right of it to shift left.

A side effect is that I can get both the hovered menu and the drop indicator that signals that the bookmark will be dropped between this and the item next to it to display making the result of the drop action ambiguous. When I let go of the button will the bookmark be added to the open menu or to the bookmark toolbar to the right of the hovered entry?

The solution seems to be to fix the icon so that the folders in the bookmark toolbar have the same width in hovered and in non-hovered state. Once that is fixed the side effect should disappear too.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 3

11 years ago
Confirmed with Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a9pre) Gecko/2007101504 Minefield/3.0a9pre

Because the icon is smaller, the right edge of the folder item shifts, and if you were trying to drop your item onto the edge of it, and not in the center, the position will be changing repeatedly, so the item may miss the folder.
Severity: normal → minor
Summary: drag & drop behaves erratic when hovering over folder on bookmark toolbar → Drag&drop-hovered bookmark folder icon is smaller than the normal one - item shift (drag & drop behaves erratic when hovering over folder on bookmark toolbar)

Comment 4

11 years ago
It's a default theme problem.

SeaMonkey has a similar problem, but vertical.
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9a9pre) Gecko/2007101502 SeaMonkey/2.0a1pre
Status: UNCONFIRMED → NEW
Component: Places → Themes
Ever confirmed: true
Product: Firefox → Core

Updated

11 years ago
Flags: blocking1.9?
There's no such thing as a default theme problem - there are copy-pasted theme bugs, and there are XUL widget bugs, but "Core: Themes" is just a misnamed "Suite: Themes"
Component: Themes → Places
Flags: blocking1.9?
Product: Core → Firefox
Well, as the folder icon is now pulled from gtk (most of the time overridden by a system icon theme) and GTK doesn't provide a "Drop into folder" icon, it'S not possible to do much here, other than:

Option A: Just use the gtk-directory icon also for the "drag into" state. This is no big deal as the menu springs open anyway, so the feedback is already there. Also, the Granparadiso icon inventory page does not list the "drag into" icon anymore, so I guess it will be removed for all platforms until FF3 is released.

Option B: We don't use folder icons at all in the toolbar. Firefox on Mac OS X already does this, as does GNOME's web browser (Epiphany).
(Reporter)

Comment 7

11 years ago
The problem is line 133 in "chrome/skin/classic/browser/browser.css" in classic.jar:

  list-style-image: url("chrome://browser/skin/places/folderDragOver.png") !important;

That icon needs to be either removed or replaced by something that adapts to the theme. I'm not sure what the proper fix for this is (remove/replace line/entire entry?) but it looks fairly trivial so I'm putting in a "polish" keyword and request blocking status to put it on the radar because this fixes both look and behavior of Firefox on Linux.
Flags: blocking-firefox3?
Keywords: polish

Updated

11 years ago
Flags: wanted-firefox3+
Flags: blocking-firefox3?
Flags: blocking-firefox3-
Priority: -- → P4
Target Milestone: --- → Firefox 3 M11
Target Milestone: Firefox 3 beta3 → ---
(Reporter)

Comment 8

11 years ago
This got fixed with the theme changes a while ago.
Status: NEW → RESOLVED
Last Resolved: 12 years ago11 years ago
Resolution: --- → FIXED
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.