In <EditorOverride.css>, 2 "Warning: Expected pseudo-element but found '-moz-XYZ'. Ruleset ignored due to bad selector."

VERIFIED FIXED

Status

--
minor
VERIFIED FIXED
13 years ago
10 years ago

People

(Reporter: sgautherie, Assigned: roc)

Tracking

({regression, verified1.8.0.5, verified1.8.1})

1.8 Branch
x86
Windows 98
regression, verified1.8.0.5, verified1.8.1
Bug Flags:
blocking1.8.0.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: regression from 331883, URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1a3) Gecko/20060618 SeaMonkey/1.1a] (nightly) (W98SE) [2006-06-18-15-mozilla1.8]

No warnings.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1a3) Gecko/20060620 SeaMonkey/1.1a] (nightly) (W98SE) [2006-06-20-03-mozilla1.8]

First time clicking 'Reply' in a session:
[[
Warning: Expected pseudo-element but found '-moz-canvas'.  Ruleset ignored due to bad selector.
Source File: resource:///res/EditorOverride.css
Line: 47

Warning: Expected pseudo-element but found '-moz-display-comboboxcontrol-frame'.  Ruleset ignored due to bad selector.
Source File: resource:///res/EditorOverride.css
Line: 113
]]

"You are not authorized to access bug #331883." could be the cause !?
Hmm. This should not be happening. It's definitely bug 331883.
Blocks: 331883
I changed the wrong function when merging to branch. I changed ReplaceStyleSheet when I should have changed AddOverrideStyleSheet. D'oh! I'll fix this tomorrow.
Created attachment 226558 [details] [diff] [review]
fix

Fixed busted merge to branch. This is a really simple fix. I guess it fixes a regression in HTML editing although I'm not really sure what the user--visible consequences are. We should get this regression fixed before we ship 1.8.0.5.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #226558 - Flags: superreview?(dbaron)
Attachment #226558 - Flags: review?(dbaron)
Attachment #226558 - Flags: approval1.8.1?
Attachment #226558 - Flags: approval1.8.0.5?
This should block 1.8.0.5 because it's regression since 1.8.0.4.
Flags: blocking1.8.0.5?
Comment on attachment 226558 [details] [diff] [review]
fix

Probably better if you don't drop the comment, but r+sr=dbaron.
Attachment #226558 - Flags: superreview?(dbaron)
Attachment #226558 - Flags: superreview+
Attachment #226558 - Flags: review?(dbaron)
Attachment #226558 - Flags: review+
Whiteboard: regression from 331883 (fixed in 1.8.0.4)
Would have been nice to get non-critical regressions nominated a lot earlier in the cycle, but looks safe enough
Flags: blocking1.8.0.5? → blocking1.8.0.5+
Comment on attachment 226558 [details] [diff] [review]
fix

approved for 1.8.0 branch, a=dveditz for drivers
Attachment #226558 - Flags: approval1.8.0.5? → approval1.8.0.5+

Updated

13 years ago
Attachment #226558 - Flags: approval1.8.1? → approval1.8.1+
This was only reported two days ago (thanks Serge!). The comment you added in the status whiteboard "(fixed in 1.8.0.4)" is actually incorrect, 331883 was fixed on branch for 1.8.0.5 on the 18th.
Whiteboard: regression from 331883 (fixed in 1.8.0.4) → regression from 331883
checked in on branches.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Keywords: fixed1.8.0.5, fixed1.8.1
Resolution: --- → FIXED

Comment 10

13 years ago
Verified FIXED using Thunderbird version 1.5.0.5 (20060622). 

Using the build Serge mentioned I saw the errors, then I downloaded a recent build with the patch in it and saw no errors.
Status: RESOLVED → VERIFIED
Keywords: fixed1.8.0.5 → verified1.8.0.5
(Reporter)

Comment 11

13 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1a3) Gecko/20060622 SeaMonkey/1.1a] (nightly) (W98SE)

V.Fixed on MOZILLA_1_8_BRANCH, between these two builds.

[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.1a3) Gecko/20060623 SeaMonkey/1.1a] (nightly) (W98SE)
Keywords: fixed1.8.1 → verified1.8.1
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.