Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 342297 - Open Containing Folder Does Not Work in Windows Vista Beta 2
: Open Containing Folder Does Not Work in Windows Vista Beta 2
: qawanted
Product: Toolkit
Classification: Components
Component: Downloads API (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
: :Paolo Amadini
Depends on:
Blocks: 352420
  Show dependency treegraph
Reported: 2006-06-21 08:02 PDT by Andrew Watiker
Modified: 2008-07-31 04:30 PDT (History)
2 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Description Andrew Watiker 2006-06-21 08:02:10 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20060508 Firefox/
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv: Gecko/20060508 Firefox/

When I download a file in Firefox on Windows Vista Beta 2 and select "Open in Containg Folder" in the downlaod manager, the software launches the file rather than opening the folder.  This happens with all file types and in all instances.

Reproducible: Always

Steps to Reproduce:
1.Download a file.
2.Right click and select "open in containing folder".

Actual Results:  
The file launched, as if I had clicked open.

Expected Results:  
The folder should have opened which contains the file.
Comment 1 Patrick 2006-06-21 08:46:20 PDT
How have you confirmed this is actually a Firefox bug, and not a Vista one? Testing a beta product on a beta product and all that ;)
Comment 2 Andrew Watiker 2006-06-21 10:32:11 PDT
I guess I have no way of knowing.  It may be a Vista bug, but it may just as easily be a different way Vista handles this sort of request which will neccesitate a code change for Firefox in the future.
Comment 3 Chris January 2006-07-05 02:04:03 PDT
Confirmed on Windows Vista Beta 2 with Firefox
Comment 4 William Bumgarner [:zsinj] 2006-09-11 13:09:19 PDT
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9a1) Gecko/20060911 Minefield/3.0a1

Windows vista Beta 2, Build 5384

Comment 5 William Bumgarner [:zsinj] 2006-09-12 17:42:06 PDT
This works fine in WinXP, so I'm confirming and reassigning to default asignee and QA contact of the component.

<- Version: Trunk
Comment 6 Doug Turner (:dougt) 2006-09-15 11:36:00 PDT
works fine in RC1 using FF 2.0 Beta 2.
Comment 7 Doug Turner (:dougt) 2006-09-19 13:36:34 PDT
wfm.  please reopen if you can reproduce this bug.

Note You need to log in before you can comment on or make changes to this bug.