Table column boundaries broken when table is in a floated fieldset

RESOLVED DUPLICATE of bug 129346

Status

()

RESOLVED DUPLICATE of bug 129346
12 years ago
12 years ago

People

(Reporter: easleydp, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

<fieldset style="float:left">
  <table border="1">
    <tr><td>Short</td><td>foo</td></tr>
    <tr><td>Longer</td><td>bar</td></tr>
  </table>
</fieldset>

The table in the above markup is presented with cells that don't align vertically, i.e. cell 'Short' really is shorter than cell 'Longer'. I'm not referring to text alignement within the cells; rather the cells themselves really are different widths (within the same column). As soon as you remove style="float:left" or change the fieldset to a div, the problem goes away.

Reproducible: Always

Steps to Reproduce:
1. paste the above code into a .html file and view

*** This bug has been marked as a duplicate of 129346 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.