document.evaluate is undefined in XULRunner browser object

RESOLVED INVALID

Status

()

Core
DOM: Core & HTML
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: markus, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: XULRunner 1.8.0.1

when trying to use the document.evaluate function in XULRunner in a <browser> object, a "TypeError: document.evaluate is not a function" exception is thrown.

Reproducible: Always

Steps to Reproduce:
1. create a xul application and add a browser object to the xulwindow:
<browser flex="1" id="browser" src="test.htm" />

2. create a test.htm file to be loaded into the xul browser:
<input type="button" onclick="alert(document.evaluate);" value="test" />

Actual Results:  
"undefined" is alerted.

Expected Results:  
"function evaluate(){
[native code]
}" should be alerted (as in firefox).
Sounds like a DOM XPath bug, like the document isn't implementing nsIDOMXPathEvaluator.

Reference http://www.w3.org/TR/2004/NOTE-DOM-Level-3-XPath-20040226/xpath.html#XPathEvaluator

Reporter: are you able to reproduce this in a trunk build / 1.8.1 branch build?
(Reporter)

Comment 2

12 years ago
i just tried the example above using the linux-version of xulrunner 1.8.0.1and it works as expected, no bug there. seems to be windows only.

i haven't yet succeeded in building xulrunner on windows and don't have access to windows here, i'll get back on that tomorrow.
(Reporter)

Comment 3

12 years ago
a fresh install of xulrunner on windows resolved the issue. looks like some files were corrupted.

i hope i haven't interrupted anyone in their precious work... sorry bout that.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID

Updated

10 years ago
Component: DOM: Core → DOM: Core & HTML
QA Contact: ian → general
You need to log in before you can comment on or make changes to this bug.