toolbar customizations disappear on restart

RESOLVED DUPLICATE of bug 307558

Status

()

Firefox
Toolbars and Customization
--
major
RESOLVED DUPLICATE of bug 307558
12 years ago
12 years ago

People

(Reporter: Brian Toms, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Whenever I make any changes to the Firefox toolbars, the toolbar works fine; however, when I close Firefox and re-open it, the toolbars have returned to the default state.  I have not been able to reproduce this problem on any other copy of Firefox, even Portable Firefox running on the same machine.

Reproducible: Always

Steps to Reproduce:
1. Right-click a toolbar and choose Customize.
2. Make changes to the toolbar.
3. Close Firefox and re-open it.

Actual Results:  
The toolbars have returned to the default layout.

Expected Results:  
My customizations should have remained.

My theory is that it may have to do with a corrupt profile.
Please see http://kb.mozillazine.org/Toolbar_customizations_reset_on_startup or the MozillaZine forums (http://forums.mozillazine.org) for end-user support.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 319196 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
Reporter, are your bookmarks also missing?
(Reporter)

Comment 4

12 years ago
No, they were not.
Brian - have you deleted the localstore.rdf as instructed from Ryan's link, and did it fix the issue? 
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

12 years ago
Yes and yes.
Thanks very much, it helps to know this issue didn't crop up again. Duping to the fixed bug.

*** This bug has been marked as a duplicate of 307558 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.