Reply All (to self sent msg) should preserve visible BCC recipients from original message

VERIFIED FIXED in Thunderbird 3

Status

Thunderbird
Message Compose Window
VERIFIED FIXED
12 years ago
11 years ago

People

(Reporter: William Price, Assigned: Magnus Melin)

Tracking

({verified1.8.1.3})

Trunk
Thunderbird 3
verified1.8.1.3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060621 Minefield/3.0a1
Build Identifier: version 3 alpha 1 (20060620)

When I send out a mass mail to a group of friends and I should be the only one receiving replies, I use BCC as a courtesy so they don't see the list of recipients.  If I want to send an update to the same group of people, the easiest way would be to choose "Reply All" to the message that I originally sent.

There's no reason to strip the BCC recipients from a reply-all because, if Thunderbird can see the BCC recipients, the message must have originated from ME and there's no loss of privacy.  (Were I a BCC recipient, I wouldn't see the other BCC'd addresses in the first place.)


Reproducible: Always

Steps to Reproduce:
1. Send a message to one or more BCC recipients other than yourself.
2. Find the message in the Sent folder.
3. Reply All


Actual Results:  
None of the BCC recipients are included in the new reply message.

Expected Results:  
BCC recipients of the original message (that are visible from the message pane) should be included *as BCC recipients* on the new reply-all message.
(Assignee)

Comment 1

12 years ago
-> new
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 2

11 years ago
duping to bug which developer has closed as INVALID. 

Excellent work arounds:
- edit message as NEW
- copy message to templates for future reuse of the address list

*** This bug has been marked as a duplicate of 292258 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
(Reporter)

Comment 3

11 years ago
I'll probably get some flack for re-opening this, because it *is* a dupe of 292258, but I strongly disagree that this and the original bug should be marked invalid.  Here's why:

Pick *any* message in your inbox.  Click "reply-all" and notice, as expected, that all visible recipients of the original message (TO and CC) are included in the reply's TO/CC fields.

Now, pick a message *you sent* with BCC recipients.  Since the sent message originated from your account and was simply copied to your Sent folder, all the BCC recipients are _visible_ in the UI.

User experience suggests that choosing "reply-all" will include all the *visible* addresses from the message pane (in this case, that includes the BCC recipients).

It's *impossible* to do on a message you received (because as we know, the BCC recipients were stripped out by the mail agent) but on one that you sent, where the data is *still* visible, there's no reason to "hide" information the user can already see.  Instead, right now it's frustrating for users (like me) who weren't aware that they could right-click the message and choose "Edit as new..."

The "Edit as new" functionality isn't as discoverable as "reply-all" and, as I've tried to show here, "reply-all" behaves in (what seems to the user) in two different ways, when they simply want to reply to all the addresses they see in the message pane.

This has nothing to do with preserving privacy, since we're talking about the sender of the original message.  Please reconsider.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 4

11 years ago
I agree this is valid, and with bug 85296 fixed it seems quite reasonable. 

I think the (not) duplicate was indeed invalid because there we did not know the BCC addresses. When replying from "Sent" folder they are known.
Summary: Reply All should preserve visible BCC recipients from original message → Reply All (in Sent folder) should preserve visible BCC recipients from original message

Comment 5

11 years ago
folders other than Sent must also work
(Assignee)

Updated

11 years ago
Summary: Reply All (in Sent folder) should preserve visible BCC recipients from original message → Reply All (to self sent msg) should preserve visible BCC recipients from original message
(Assignee)

Comment 6

11 years ago
Created attachment 246054 [details] [diff] [review]
proposed fix

Preserve the BCC headers if they exist (like for the reply-to-self case). 

Also some whitespace cleanup: removes a few double new lines, extra spaces at line starts of empty lines and a few tabs I spotted. Will attach a -uw patch for easier reading.
Assignee: mscott → mkmelin+mozilla
Status: REOPENED → ASSIGNED
Attachment #246054 - Flags: superreview?(bienvenu)
Attachment #246054 - Flags: review?(bienvenu)
(Assignee)

Comment 7

11 years ago
Created attachment 246055 [details] [diff] [review]
proposed fix (diff -uw)

Comment 8

11 years ago
Comment on attachment 246054 [details] [diff] [review]
proposed fix

nice, thanks.
Attachment #246054 - Flags: superreview?(bienvenu)
Attachment #246054 - Flags: superreview+
Attachment #246054 - Flags: review?(bienvenu)
Attachment #246054 - Flags: review+
(Assignee)

Comment 9

11 years ago
Gavin, want to check this in? 
Whiteboard: [checkin needed]
(In reply to comment #9)
> Gavin, want to check this in? 

Sure thing! :)

mozilla/mailnews/compose/src/nsMsgCompose.cpp 	1.498
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Thunderbird 3
(Assignee)

Updated

11 years ago
Attachment #246054 - Flags: approval-thunderbird2?

Updated

11 years ago
Attachment #246054 - Flags: approval-thunderbird2? → approval-thunderbird2+
(Assignee)

Updated

11 years ago
Whiteboard: [checkin needed (1.8 branch)]
mozilla/mailnews/compose/src/nsMsgCompose.cpp 	1.460.2.27
Keywords: fixed1.8.1.2
Whiteboard: [checkin needed (1.8 branch)]
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 Thunderbird 2 RC1 - tested with the steps to reproduce from comment #0
are ncluded as BCC recipients on the new reply-all message.
Keywords: fixed1.8.1.2 → verified1.8.1.3
(Reporter)

Comment 13

11 years ago
Also verified [version 3 alpha 1 (20070227)]; thanks everyone.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.