Printing semi-transparent PNGs does not work.

RESOLVED DUPLICATE of bug 191099

Status

()

RESOLVED DUPLICATE of bug 191099
12 years ago
12 years ago

People

(Reporter: fireman, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

Under Windows XP and Firefox 1.5.0.4, I cannot print semi-transparent (256 alpha) PNG's correctly. Look at this page, please:
http://users.skynet.be/clodius/pngtest.html
It show two hand-written "A"'s on top of eachother. Now print this file, and you will see that
1) The transparent background turns black
2) Transparency is not preserved, as the first image clearly covers a part of the second

I believe this is the same bug as https://bugzilla.mozilla.org/show_bug.cgi?id=202795, but since that seemed to be Mac specific, I thought I had to make a new bug report for it.

Reproducible: Always

Steps to Reproduce:
1. Go to http://users.skynet.be/clodius/pngtest.html
2. Print
3. Look at the results, and compare with the page that Firefox renders in the browser.

Actual Results:  
Transparency is not preserved

Expected Results:  
The two images must not cover eachother, but must fade one on top of the other.

This bug is also present in other browsers (I have tried IE, it gives a grey background, and Opera only does 1 or 0 transparency (like a GIF))
(Reporter)

Updated

12 years ago
Summary: Printing semi-transparent PNG's does not work. → Printing semi-transparent PNGs does not work.

Comment 1

12 years ago
Comment in https://bugzilla.mozilla.org/show_bug.cgi?id=141656#c34
say that is fixed on windows ... it is not the case

--> bug 141656 resolved this bug for linux
--> bug 202795 is mac specific indeed
--> bug 191099 refers to this bug for windows 2000 platform

--> duplicate 

*** This bug has been marked as a duplicate of 191099 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.