Attempt to create IMAP folder name with percent sign "%" should create error message as "Invalid Mailbox Name". Currently no dialog box pops up

RESOLVED DUPLICATE of bug 316325

Status

MailNews Core
Networking: IMAP
--
minor
RESOLVED DUPLICATE of bug 316325
12 years ago
10 years ago

People

(Reporter: Louie Swalby, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.2) Gecko/20040804 Netscape/7.2 (ax)

When client uses TBird 1.5.02, and attempts to create folder name on the IMAP server (SUNOne 5.2) with a percent sign (eg: Design 65%), no feed back is given to the user from IMAP server indicating that it is an invalid folder name.  However, when using the Outlook client with same IMAP server,  and attemtping to create the referenced folder, the Outlook program responds:  Unable to create the Folder.  The server responded "Invalid Mailbox name"
It appears that TBird is not trapping the IMAP server response and responding to it.

Reproducible: Always

Steps to Reproduce:
1.Attempt to create folder with folder with % in name on IMAP server, Hit OK
2.Thunderbird gives no feedback that it cannot be done. Folder not generated
3. 

Actual Results:  
Folder not created as expected, but no dialog box comes up indicting to the user that the reason was an invalid mailbox or folder name

Expected Results:  
A dialog box should appear indicating to the user that the server responded with an "Invalid Mailbox name"

Users deduce after multiple attempts that the "%" character in the folder name will not work.

NOTE: RFC 3501, section 5.1 does however indicate that the "%" can be used in a folder name, but does not advise it.  The SUNOne 5.2 server apparently does not like use of the "%" and does send an error message back to the IMAP client as seen by the Outlook client and the web interface for the SUNOne server.

Comment 1

12 years ago
Reproduced on Fastmail, TB 2b1-1111 and SM 1.5a-0925, Win2K.
Assignee: mscott → bienvenu
Status: UNCONFIRMED → NEW
Component: General → Networking: IMAP
Ever confirmed: true
OS: Windows XP → Windows 2000
Product: Thunderbird → Core
QA Contact: general → grylchan
Summary: Attempt to create IMAP folder name with pecent sign "%" should create error message as "Invalid Mailbox Name". Currently no dialog box pops up → Attempt to create IMAP folder name with percent sign "%" should create error message as "Invalid Mailbox Name". Currently no dialog box pops up
Version: unspecified → Trunk

Comment 2

12 years ago
Linux too, latest branch.
OS: Windows 2000 → All
Hardware: PC → All

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 316325
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.