Scrolling causes the page to tear vertically

VERIFIED DUPLICATE of bug 160435

Status

VERIFIED DUPLICATE of bug 160435
12 years ago
12 years ago

People

(Reporter: gslusher, Unassigned)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2

When scrolling, parts of the page move and others don't, then they do move. It never pops back into alignment. There was a previously reported bug where fast scrolling caused tearing, but, when the scrolling stopped, it popped back into alignment. In this case, it happens no matter how slowly I scroll.

I had a similar problem with Safari 1.3.2, but I traced it to the utility CopyPaste. However, CopyPaste was not running when this incident happened. 

I tried it in Firefox 1.5.0.4. One of the pictures on the right moves in a jerky way when scrolling, but it's nowhere near as bad as in Camino. It works as expected in Safari 1.3.2, Opera 9.0, Shiira 1.2.2, Sea Monkey 1.0.2, and iCab (latest release). 

Reproducible: Always

Steps to Reproduce:
1. Open URL.
2. Scroll vertically.

Actual Results:  
Page tears vertically.

Expected Results:  
Normal scrolling--parts of the page move up and down in sync.

Comment 1

12 years ago
WFM here. It's all images and QT, so I'm not sure what could be causing this.  Are you sure you're not running any other conflicting apps?
(Reporter)

Comment 2

12 years ago
The only things that were running at the time were background functions, including F10 Launch Studio and Kensington MouseWorks. I logged out of my normal user and logged into a pristine user account I use for troubleshooting. It has had nothing added--my Kensington trackball's functions were unavailable, for example. I confirmed that the page still tears in Camino. Try it in OS 10.3.9, if you can. I don't know how it would behave in Tiger.

What's more strange is that Firefox doesn't have the problem, though the QT bit on the right jerks as one scrolls, leaving multiple images until you stop scrolling. Sea Monkey works OK, as do Safari 1.3.2, Opera 9, Shiira, and iCab. Thus, it must be something peculiar to Camino. 

Comment 3

12 years ago
This may be a dupe of either bug 160435 or bug 301152 (the latter being supposedly 10.4-only, but may not actually be 10.4-only).

cl
(Reporter)

Comment 4

12 years ago
Created attachment 226600 [details]
screenshot of the tearing

This shows what the "tearing" looks like. I can do other screenshots and/or video.
It's clearly bug 160435 ;)  I think that bug has gotten worse recently, maybe with QT 7.x.

/me glares at a certain QT developer ;)

*** This bug has been marked as a duplicate of 160435 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 6

12 years ago
Here's another page that tears in strange ways. 

http://www.macnightowl.com/newsletter/2006/07/03/newsletter-issue-344/

It does not seem to have any QuickTIme movies. I tried to tell you that it wasn't a duplicate of the other problem, as the behavior is different. Also, I've seen a similar thing on YouTube and with YouTube "movies," which are .flv (flash video) format, which QuickTime does NOT play. For example:

http://atrios.blogspot.com/2006_07_02_atrios_archive.html



You need to log in before you can comment on or make changes to this bug.