I find myself writing do_check_eq(... , true); a whole lot. do_ensure would just save some typing. ;)
Created attachment 226612 [details] [diff] [review] Like so
I'm leaning towards standardizing on *unit-named tests, like assertTrue, assertEquals, ... Also, I'm not sure how long-lived this set of methods will be, since it may be easier to port tests to a slightly different harness (still based on xpcshell, but more like jsunit) than to try to add the reporting and invocation infrastructure to this set of code. As a short-term comprimise, would you be willing to rename do_ensure() to do_check_true()? -Dave, who with this comment just wiped out the amount of typing saved in test cases
Created attachment 226654 [details] [diff] [review] With do_check_true
Checked in. Thanks!
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Er, actually checked in now for real.
You need to log in before you can comment on or make changes to this bug.