Inline SVG elements do not obey z-index rules

RESOLVED INVALID

Status

()

Core
SVG
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Martin Kou, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

In the XHTML file given, there exist at least three distinct layers:

z-index = 1: the bottom text
z-index = 100: the svg graphics
z-index = 200: the upper text

The svg graphics should appear between the two layers of texts. What actually happens is that the graphics always appear at the bottom no matter what z-index they have.

Reproducible: Always

Steps to Reproduce:
1. Write a XHTML, with some inline SVG elements and some regular elements
2. Set the inline SVG elements' z-index higher than that of regular elements

Actual Results:  
The SVG elements appears at the bottom no matter what

Expected Results:  
The SVG elements should by layered with the regular HTML elements according to the z-index order.

Comment 1

12 years ago
Robert, can you shed some light on why outer svg frames aren't getting correctly shuffled into the display deck?
The z-index on the SVG DIV is ignored because the DIV is not positioned. z-index only applies to positioned elements.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.