The Autoupdate feature does not work on Linux.

RESOLVED DUPLICATE of bug 318855

Status

()

defect
--
major
RESOLVED DUPLICATE of bug 318855
13 years ago
11 years ago

People

(Reporter: hmohan, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060124 Firefox/1.5.0.1

The Automatic Update for Firefox does not at all on Linux Boxes. I have to download the complete tar ball of Firefox to update it. This problem has been existing in all Version 1.5x on Linux. I have tested it both on FC3 and Suse9.x boxes.
It works fine on M$ OSes.
The same problem also exists for Thunderbird 1.5x.
The extensions seems to work fine.



Reproducible: Always

Steps to Reproduce:
1. The Edit->Preferences->Advanced->Update has all update options checked (enabled). The Firefox option is greyed out.
2. The Check for updates featue in under Help Menu is disabled.


Actual Results:  
The Automatic Updates do not happen
The Check for Updates feature under Help Menu is disabled

Expected Results:  
The Check for Updates in the Help Menu should be enabled.
Firefox should check for updates when the user clicks on the Check for Updates .


There are no automatic updates 
The user has to download the complete Firefox tarball to upgrade to the latest version, loosing all the installed plugins  (installed system wide) in the process.
You need to have write access to the application install dir to update. A normal user on linux usually won't have that for a system wide install.

Bug 318855 is for still checking for updates while not running as root, with prompt for root password to apply an update. This is probably a duplicate of that.
I would agree with comment #1.

*** This bug has been marked as a duplicate of 318855 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.