layout goes into an infinite loop when viewing file

RESOLVED INVALID

Status

()

Core
Layout
P3
normal
RESOLVED INVALID
19 years ago
18 years ago

People

(Reporter: blizzard, Assigned: clayton)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
When viewing the file I'll attach in a second it appears that layout goes into
an infinite loop.  There's lots of this:

nsBlockReflowContext: TitledButton[value=]@0x88c58e8 metrics=870375,285!
Block(div)(1)@0x88c58a0: line=0x88c5a3c xmost=870375
Block(div)(1)@0x88c58a0: WARNING: desired:870285,375
nsBlockReflowContext: TitledButton[value=]@0x88c58e8 metrics=870465,285!
Block(div)(1)@0x88c58a0: line=0x88c5a3c xmost=870465
Block(div)(1)@0x88c58a0: WARNING: desired:870375,375
Block(div)(2)@0x88c5a64: WARNING: desired:870285,195
Block(div)(0)@0x88c57f4: WARNING: desired:870285,195
Block(div)(0)@0x88c57f4: WARNING: desired:870465,195
nsBlockReflowContext: TitledButton[value=]@0x88c58e8 metrics=870465,285!
Block(div)(1)@0x88c58a0: line=0x88c5a3c xmost=870465
Block(div)(1)@0x88c58a0: WARNING: desired:870375,285
nsBlockReflowContext: TitledButton[value=]@0x88c58e8 metrics=870555,285!
Block(div)(1)@0x88c58a0: line=0x88c5a3c xmost=870555
Block(div)(1)@0x88c58a0: WARNING: desired:870465,285

This file was created when I took a text file and converted it to UCS-4 so it
uses 4 bytes for each regular byte.
(Reporter)

Comment 1

19 years ago
Created attachment 7173 [details]
encoded binary file

Comment 2

19 years ago
This is not a layout problem, we should not be trying to lay out binary files
Assignee: troy → don
Component: Layout → XPApps
QA Contact: petersen → paulmac

Comment 3

19 years ago
changing qa contact to jrgm@netscape.com on some random bugs
QA Contact: paulmac → jrgm

Comment 4

18 years ago
Reassigning as per Don
Assignee: don → clayton
Component: XPApps → Layout
QA Contact: jrgm → petersen

Comment 5

18 years ago
I'm not seeing any problem.

Here is what I did.

1) Loaded http://bugzilla.mozilla.org/show_bug.cgi"?id=34251 in viewer/mozilla
2) Clicked on the attachment ("encoded binary file").
3) Got a pop-up to save the file (I guess that's the correct behavior ).
4) Successfully saved the attachement on my hard disk.

Marking bug INVALID
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.