correcting word (with spell checker) causes other words to be unhighlighted

RESOLVED FIXED

Status

()

Core
Spelling checker
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Martijn Wargers (zombie), Assigned: Scott MacGregor)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
To reproduce:
- Type the following in a textarea: wone twoo
- Enable spellchecking on the textarea, both words get highlighted
- Right-click "wone" and select "one"."
Result, the other word becomes unhighlighted.

This is a regression from bug 312778, backing out the "remove the redundant DeleteSelection call" patch fixes it. 
I guess that patch just needs to be backed out, since it appears to be not that redundant at all.
(Reporter)

Comment 1

12 years ago
Checking in extensions/spellcheck/src/mozInlineSpellChecker.cpp;
/cvsroot/mozilla/extensions/spellcheck/src/mozInlineSpellChecker.cpp,v  <--  moz
InlineSpellChecker.cpp
new revision: 1.17; previous revision: 1.16
done

Ok, backed out the offending patch.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.