table-layout: fixed with col visibility: collapse fails to hide column

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: reid.kleckner, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When a table is specified with table-layout: fixed, setting the visibility of a column to collapse either dynamically or right off of the page load has no effect. The example page contains a COL element with styling set to visibility: collapse, and clicking the "hide" text dynamically sets that styling but neither have any visible effect. 

Reproducible: Always

Actual Results:  
The columns were still visible.  Nothing happened and no errors were generated.

Expected Results:  
The columns should have been hidden from view.
(Reporter)

Comment 1

12 years ago
Created attachment 226832 [details]
Test page to demonstrate behavior.

Comment 2

12 years ago
Created attachment 226901 [details]
Simplified testcase

Thanks for reporting this bug.

For the future: a simplified testcase really means as simple as possible.  If you don't need scripts, get rid of them.  If you don't need extra columns, don't include them.  It's just confusing when the problem isn't instantly obvious, and the code the causes the problem is mixed with other irrelevant code.

Comment 3

12 years ago
(Confirming with current trunk.)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: testcase
Summary: table-layout: fixed with col visibility: collapse fails → table-layout: fixed with col visibility: collapse fails to hide column

Comment 4

12 years ago
Hmm, seems to work with a current build; marking WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.