Error always appears while reviewing, if you own an add-on in the queue

VERIFIED DUPLICATE of bug 350904

Status

addons.mozilla.org Graveyard
Developer Pages
--
minor
VERIFIED DUPLICATE of bug 350904
12 years ago
2 years ago

People

(Reporter: Tim Horton, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.0.3705; .NET CLR 1.1.4322; Media Center PC 4.0)
Build Identifier: 

Each and every time I review an extension, whether I accept or reject it, I get the following error message:

Error: Denial cannot be processed because of missing data. Fill in the required fields and try again.

However, above this, I get a message telling me that the change was successful, and the extension falls out of the queue!

Reproducible: Always

Steps to Reproduce:
1. Review an extension
2. Submit
3. View the results (at the top of the next page)

Actual Results:  
The action happens, but Update returns a message:

Error: Denial cannot be processed because of missing data. Fill in the required fields and try again.

Expected Results:  
The action should happen, and I should ONLY recieve the confirmation of the action.

Comment 1

12 years ago
You must fill in the OS, App and comments field and check ALL the boxes to approve an Add-on.

You must fill in the OS, App and comments fields to deny an add-on.

Are you doing that?
(Reporter)

Comment 2

12 years ago
(In reply to comment #1)
> You must fill in the OS, App and comments field and check ALL the boxes to
> approve an Add-on.
> 
> You must fill in the OS, App and comments fields to deny an add-on.
> 
> Are you doing that?
> 
 Yep. I'm filling everything in, and MY action happens - lets say I accept one extension. I get 'such and such was accepted' and the right under it, 'Error: Denial cannot be processed because of missing data. Fill in the required fields and try again.'

That second message is _always_ one about denial, even if I was only accepting an extension.

So - it doesn't actually break anything, it just leaves an annoying message that sometimes makes me think I screwed up...
(Reporter)

Comment 3

12 years ago
I think I know what's causing this now. I just reviewed an extension _below_ my own in the list, and voila! The error message comes first, before the acceptance line.

So - I'm saying that it only happens if you have an extension of your own in the queue.
Confirming, adjusting summary, etc.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Component: Developer Pages → Administration
Ever confirmed: true
Summary: Error always appears while reviewing → Error always appears while reviewing, if you own an extension in the queue

Updated

12 years ago
Component: Administration → Developer Pages
Summary: Error always appears while reviewing, if you own an extension in the queue → Error always appears while reviewing, if you own an add-on in the queue

Comment 5

12 years ago
*** Bug 343399 has been marked as a duplicate of this bug. ***
I fixed this a couple weeks ago after submitting my own bug for it - didn't know there was already one. Oops!

Anyway, this is fixed now.

*** This bug has been marked as a duplicate of 350904 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE

Updated

11 years ago
Status: RESOLVED → VERIFIED
Version: unspecified → 1.0
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.