If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

WARNING: NS_ENSURE_TRUE(aURI) failed

RESOLVED WORKSFORME

Status

SeaMonkey
Tabbed Browser
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: mats, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
STEPS TO REPRODUCE
1. go to any URL which have some links, e.g. http://www.mozilla.com/
2. middle-click a link

The bug occurs with "Middle-click opens new tab" preference on.
The bug does not occur with "Middle-click opens new tab" preference off or
when left-clicking a link.

ACTUAL RESULTS
WARNING: NS_ENSURE_TRUE(aURI) failed: file nsDefaultURIFixup.cpp, line 75

PLATFORMS AND BUILDS TESTED
Bug occurs in SeaMonkey debug build on Linux, about 1 day old.
Bug occurs in SeaMonkey debug build on Linux, about 2 weeks old.
Bug does not occur in Firefox debug build on Linux, about a week old.
(so it seems to me it is a SeaMonkey only problem, but I could be wrong)

Comment 1

11 years ago
Created attachment 226962 [details]
native stack

Comment 2

11 years ago
Created attachment 226963 [details]
and the JS stack

Comment 3

11 years ago
looks like tabbedbrowser + favicons
Assignee: general → nobody
Component: General → Tabbed Browser
Product: Mozilla Application Suite → Core
QA Contact: general → tabbed-browser
This most likely occurs as a result of bug 113202.

Comment 5

11 years ago
(In reply to comment #4)
>This most likely occurs as a result of bug 113202.
You're right, I broke the null-check by adding stuff before it.

Comment 6

11 years ago
*** Bug 349990 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

9 years ago
Product: Core → SeaMonkey

Comment 7

9 years ago
This particular stack is WFM. Bug 425480 has resulted in a new regression which includes triggering this warning as a side-effect, so I filed bug 482147.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.