Close button on first tab is disabled with just one tab open

VERIFIED WONTFIX

Status

--
minor
VERIFIED WONTFIX
13 years ago
9 years ago

People

(Reporter: lensovetp, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060614 Camino/1.0+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.1a3) Gecko/20060614 Camino/1.0+

If the tab bar is always visible and only one tab is open, the close button is disabled. It would be much more convinient if the button stayed enabled and did what it would normally do - close the tab.

Firefox has interesting behavior in relation to this - it closes the tab, but immediately opens a new one with a blank page. I'd say that's not really what we want here.

Reproducible: Always

Steps to Reproduce:
1. Make sure tab bar is always visible
2. Have just one tab open
Actual Results:  
Close button is disabled.

Expected Results:  
Close button is enabled and functions as it would in any other case.

Comment 1

13 years ago
This is by design; see bug 291758.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> This is by design; see bug 291758.
> 

well during discussion of that bug it was mentioned that my behavior is one option, and the current behavior is the other option. my question is, why was the latter chosen as the "expected" behavior?
Because the behavior we chose is consistent with the OS and keeps the tab close button consistent with itself (i.e., it always closes a tab, not a window): "b) I
think it would be just weird and "inconsistant" if trying to close a tab would
close a window"
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

13 years ago
well...just because in this case, closing the tab also closes a window, well duh...if it's the only tab, closing the tab closes the window too.
dunno, to me it seems "consistent" that the button always works and always closes a tab. now, since one tab = whole window, then the last tab would close the window too. seems pretty consistent to me.
ahh resistance is futile...

Updated

9 years ago
Duplicate of this bug: 535733
You need to log in before you can comment on or make changes to this bug.