When a Web Page Sends a PDF Document, Want to Save It Instead of Loading It, or At Least Be Asked

RESOLVED DUPLICATE of bug 19118

Status

SeaMonkey
General
--
major
RESOLVED DUPLICATE of bug 19118
12 years ago
12 years ago

People

(Reporter: James B. Higgs, Unassigned)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2 Mnenhy/0.7.4.0
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8.0.4) Gecko/20060516 SeaMonkey/1.0.2 Mnenhy/0.7.4.0

When web pages send PDF Documents, they usually end up being huge reource hogs,
my browser and mail/news windows start displaying incorrectly (right sides,
tops and bottoms disappear, I have to use a script program I have to resize
them correctly *after* I have unloaded the PDF file) and I have to save them
to disk, exit SeaMonkey, and run Adobe to view them properly anyway, so I
would like to keep them from loading in the first place. I would like the
option to configure SeaMonkey *not* to use a given plugin by default, but to
bring up a dialog asking me whether to Open or Save the file, preferably with
that "Always perform this action on this file type" checkbox included.

(This would have the added benefit of allowing me to save JibJab files to disk,
after I've viewed them. :> )

Jim H. (aka CuriousJ)


Reproducible: Sometimes

Steps to Reproduce:
1. Load a web page with a largish Adobe PDF document in it.

Actual Results:  
Screws up entire SeaMonkey application royally, I have to save PDF document to
disk, hit the Back button to get out of it, respond to the protests about closing
the PDF document, correct the sizing of my windows, note where I am in all my windows, exit SeaMonkey, shut down and reboot, and return to SeaMonkey.


Expected Results:  
Expect to be *asked* whether I want to open a 3rd-party document or not.

Comment 1

12 years ago
If you don't want to load PDFs in the browser, just remove the plugin...

The rest of this is covered by "Plug-In Manager (ui for choosing mimetype-plugin associations)"

*** This bug has been marked as a duplicate of 19118 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
You need to log in before you can comment on or make changes to this bug.