Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.PurgeHistory]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame ::

VERIFIED FIXED in mozilla1.8.1beta2

Status

()

Toolkit
XUL Widgets
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Bryan, Assigned: Simon Bünzli)

Tracking

({fixed1.8.1})

1.8 Branch
mozilla1.8.1beta2
fixed1.8.1
Points:
---
Bug Flags:
blocking-firefox2 -
in-testsuite ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060624 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060624 BonEcho/2.0a3

Under specific conditions an exception is generated in the Error Console when "Clear Private Data" is used:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.PurgeHistory]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/browser.xml :: observe :: line 637" data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 637

Reproducible: Always

Steps to Reproduce:
1) Set about:config javascript.options.showInConsole = true
2) Open two tabs and load two sites, one in each tab. Allow each tab to completely load it's content
3) Launch Error Console and "clear" all events, minimize the Error Console
4) Select the second tab and click a link in that tab that will load a new page in that tab
5) Clear Private Data (CPD should be configured to clear at least browsing history)
6) You should observe the following error in the Error Console: 

Actual Results:  
An exception is generated in the Error Console when "Clear Private Data" is used:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.PurgeHistory]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/browser.xml :: observe :: line 637" data: no]
Source File: chrome://global/content/bindings/browser.xml
Line: 637

Expected Results:  
No exception generated in the Error Console when using "Clear Private Data".
(Reporter)

Updated

12 years ago
Flags: blocking-firefox2?

Updated

12 years ago
URL: N/A
Not a blocker, what is happening is that the call at http://lxr.mozilla.org/mozilla/source/toolkit/content/widgets/browser.xml#662 is failing because there isn't any session history to purge in the first tab, but its not a harmful exception because of how it gets invoked.  Everything that should be cleared gets cleared.  We should still check for purge > 0 at the call linked above.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox2? → blocking-firefox2-
Do you have an extension installed that deletes history per item?
I once had such an extension (don't know its name anymore) and every time when I clicked "Remove this item from history" a new similar error was added to the console (but the exension seems to work). I stopped using it because it deleted also the whole session history under that tab (Back stopped working).
Excuse; didn't read the steps to reproduce well because I suddenly recognized the well-known error in the summary. But I assume it is the same issue.
(Reporter)

Comment 5

12 years ago
(In reply to comment #2)
> Do you have an extension installed that deletes history per item?
> 

I experience the same issue during safe mode following the steps to reproduce above.

~B

(Assignee)

Comment 6

12 years ago
Created attachment 230635 [details] [diff] [review]
trivial fix
Attachment #230635 - Flags: review?(mconnor)
(Assignee)

Updated

12 years ago
Component: History → XUL Widgets
Flags: review?(mconnor)
OS: Windows XP → All
Product: Firefox → Toolkit
Hardware: PC → All
Target Milestone: --- → mozilla1.8.1beta2
(Assignee)

Updated

12 years ago
Attachment #230635 - Flags: first-review?(mconnor)
(Reporter)

Updated

12 years ago
Whiteboard: [has patch]
QA Contact: history → xul.widgets
(Assignee)

Updated

12 years ago
Attachment #230635 - Flags: first-review?(mconnor) → first-review?(bugs.mano)
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED
Whiteboard: [has patch] → [has patch][needs review asaf]
Assignee: nobody → zeniko
Status: ASSIGNED → NEW
Comment on attachment 230635 [details] [diff] [review]
trivial fix

r=mano
Attachment #230635 - Flags: first-review?(bugs.mano) → first-review+
(Assignee)

Updated

12 years ago
Whiteboard: [has patch][needs review asaf] → [has patch][checkin needed]
(Reporter)

Comment 8

12 years ago
Don't care about this anymore.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
Status: REOPENED → NEW
mozilla/toolkit/content/widgets/browser.xml 	1.92
Status: NEW → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED
Whiteboard: [has patch][checkin needed] → [needs approval]
Version: unspecified → 1.8 Branch
(Assignee)

Comment 10

12 years ago
Comment on attachment 230635 [details] [diff] [review]
trivial fix

Drivers: This one-line patch prevents an exception by checking whether there are history entries to be purged before actually doing so. Risk: very low.
Attachment #230635 - Flags: approval1.8.1?
Comment on attachment 230635 [details] [diff] [review]
trivial fix

a=drivers, please checkin on the 181 branch.
Attachment #230635 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

12 years ago
Whiteboard: [needs approval] → [checkin needed (1.8 branch)]
mozilla/toolkit/content/widgets/browser.xml 	1.70.2.15
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
*** Bug 296694 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED

Updated

12 years ago
Flags: in-testsuite?
You need to log in before you can comment on or make changes to this bug.