mozilla forced layers to left=0 top=0 ,,, with MSIE works ...with mozilla not!

RESOLVED DUPLICATE of bug 125303

Status

()

--
major
RESOLVED DUPLICATE of bug 125303
13 years ago
13 years ago

People

(Reporter: massimo.bonomo, Assigned: dbaron)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; it; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

this is the code :

<div  style='position:relative;  z-index:1; left: 0px; top: 0px'><img  src='images/cartografia/11.gif'>
<div  style='position:absolute;  z-index:1; left: 248 px; top: -6 px'><img id="src20" src='images/territori/r/Ucraina.gif'></div>
<div  style='position:absolute;  z-index:1; left: 248 px; top: -6 px'><img id="src20" src='images/territori/contorni/Ucraina.gif'></div>
<div  style='position:absolute;  z-index:1; left: 178 px; top: -17 px'><img id="src16" src='images/territori/free/Scandinavia.gif'></div>
<div  style='position:absolute;  z-index:1; left: 150 px; top: 102 px'><img id="src17" src='images/territori/free/Europa-Settentrionale.gif'></div>
<div  style='position:absolute;  z-index:1; left: 152 px; top: 164 px'><img id="src19" src='images/territori/3/Europa-Meridionale.gif'></div>
<div  style='position:absolute;  z-index:1; left: 265 px; top: 222 px'><img id="src27" src='images/territori/3/Medio-Oriente.gif'></div>
<div  style='position:absolute;  z-index:1; left: 326 px; top: 107 px'><img id="src30" src='images/territori/3/Afghanistan.gif'></div>
<div  style='position:absolute;  z-index:1; left: 326 px; top: 107 px'><img id="src30" src='images/territori/7/Afghanistan.gif'></div>
<div  style='position:absolute;  z-index:1; left: 327 px; top: -6 px'><img id="src36" src='images/territori/free/Urali.gif'></div>
<div id=conquer style='position:absolute;  z-index:4; left: 272 px; top: 120 px'><font class=nome id=nomet><br>Eastern<br>Europe</font></div>
<div id=conquer style='position:absolute;  z-index:4; left: 184 px; top: 40 px'><font class=nome id=nomet><br>Northern<br>Europe</font></div>
<div id=conquer style='position:absolute;  z-index:4; left: 158 px; top: 129 px'><font class=nome id=nomet><br>Central Europe</font></div>
<div id=conquer style='position:absolute;  z-index:4; left: 176 px; top: 183 px'><font class=nome id=nomet><br>Southern Europe</font></div>
<div id=conquer style='position:absolute;  z-index:4; left: 334 px; top: 283 px'><font class=nome id=nomet><br>Middle East</font></div>
<div id=conquer style='position:absolute;  z-index:4; left: 364 px; top: 136 px'><font class=nome id=nomet><br>Afghanistan</font></div>
<div id=conquer style='position:absolute;  z-index:4; left: 344 px; top: 73 px'><font class=nome id=nomet><br>Urals</font></div>
</div>



Reproducible: Always

Steps to Reproduce:
1.simply open the link with firefox or netscape or ... other mozilla browswer . 
2.
3.

Actual Results:  
layer absolutely uncontrollable have left: 0 px; top: 0 px

Expected Results:  
correct layer position
*** Bug 342668 has been marked as a duplicate of this bug. ***

Comment 2

13 years ago
Warning: Expected end of value for property but found 'px'.  Error in parsing value for property 'top'.  Declaration dropped.
Source File: http://www.tru-program.com/lega/WTFmozilla.htm
Line: 0

Error Console correctly complains at the space between number and units (px).

Comment 3

13 years ago
As comment 2 says, you are setting the values to "top:2 px", when it should be "top:2px"

Updated

13 years ago
Assignee: nobody → dbaron
Component: General → Style System (CSS)
Keywords: testcase
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → Trunk

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 125303 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.