Small issue: Translation mistake in one of the error pages (Spanish)

RESOLVED FIXED in mozilla2.0

Status

Mozilla Localizations
es-ES / Spanish
--
trivial
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: OMA, Assigned: Andrés G. Aragoneses)

Tracking

unspecified
mozilla2.0
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: P1, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; es-ES; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

One of the error pages in Spanish (Spain) version of Firefox has as mistake, since it includes the same sentence in Spanish and English:
___

Archivo no encontrado

Firefox no puede encontrar el archivo en /xxxxxxxx/xxxxxxxxxxxx.xxx.

    *   Compruebe que ha escrito correctamente las mayúsculas en el nombre del ficheroCheck the file name for capitalization or other typing errors.

    *   Compruebe que el fichero no haya sido movido, renombrado o eliminado.
___

As you can see there are two sentences (one in Spanish and the other in English) "merged" into one. The correct sentence should be something like: "Compruebe que ha escrito correctamente las mayúsculas en el nombre del fichero o cualquier otro error al teclear".

Reproducible: Always

Steps to Reproduce:
Get to that error message in Spanish (Spain) version of Firefox. That error appeared in my machine while having an incorect TEMP environment variable (it pointed to a non-existent hard disk drive, since I took that disk off the computer).
Actual Results:  
Got the above reproduced error message with that mistake in the translation.

Expected Results:  
A well translated error message ;)

...or even no error message at all! (see below suggestion in "Additional Information")

Apart from fixing that small mistake, maybe Firefox could be modified so if the user has a wrongly set "TEMP"/"TMP" variable (for example a non-existent "X:\Temp"), it falls back to a default C:\Temp or something like that, instead of showing an error message which doesn't even clue about having a wrong TEMP variable (I discovered that was the source of the problem after some fiddling).

Or maybe it would be enough to warn the user about having a TEMP variable pointing to an inexistent disk, instead of that generic "File not found" message, which doesn't help much to find what's the problem.

Updated

12 years ago
Component: File Handling → General
QA Contact: file.handling → general
Andres, please fix this for fx2. I have set the URL to the lxr place where 
the source for this bug is.
Assignee: nobody → knocte
Status: UNCONFIRMED → NEW
Component: General → es-ES / Spanish
Ever confirmed: true
Product: Firefox → Mozilla Localizations
Whiteboard: P1
Target Milestone: --- → mozilla1.9final
-> (approximately) default QA assignee.
QA Contact: general → nobody
(In reply to comment #1)
> Andres, please fix this for fx2. I have set the URL to the lxr place where 
> the source for this bug is.
> 


It has been a while since I last contacted with Andrés. I'm going to file a bug to request CVS access, but I'm a bit lost when it comes to commiting changes to CVS, and we (es-ES) are actually behind schedule.
Fix checked in branch by me.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.