a single ctrl-click on a link can both open a new tab AND navigate in the current tab

RESOLVED DUPLICATE of bug 151142

Status

()

--
minor
RESOLVED DUPLICATE of bug 151142
13 years ago
13 years ago

People

(Reporter: ifreecarve, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

with the correct timing of your ctrl-clicking a link in the browser window, it is possible to open a new tab with the link target AND the current tab will navigate to that link.

Reproducible: Sometimes

Steps to Reproduce:
1. go to http://about.com ... i can reproduce it here pretty reliably
2. choose a link to click on, but don't click yet
3. the timing to reproduce this bug is to hold down the ctrl key first, then left click, and release the mouse button.  
4. release the ctrl key immediately.  sometimes this seems to affect the outcome, sometimes it doesn't

Actual Results:  
in some cases, the browser opens a new tab with the link target AND navigates in the current window.  sometimes i can reproduce this behavior when the release of the ctrl key is very close to the release of the mouse button (if you release ctrl too soon, it will just open the link in the current tab).  other times, this will happen without me releasing the ctrl key at all.  its best to experiment by ctrl-clicking and releasing the ctrl key closer and closer to the release of the mouse button.

Expected Results:  
in no case should the software open a new tab AND navigate (2 distinct and separate actions) in a single click of the mouse.  if a new tab is being opened, the current page should not budge.  

i can reproduce this most often on the about.com website, but not the netscape.net website.  to me, that suggests some interaction with javascript is the problem.
about.com has an onclick handler that changes location.href, so that's pure bug 151142.

*** This bug has been marked as a duplicate of 151142 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.