Unable to Remove Tags for IMAP Messages

RESOLVED FIXED in Thunderbird2.0

Status

Thunderbird
Mail Window Front End
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Scott MacGregor, Assigned: Bienvenu)

Tracking

({fixed1.8.1, verified1.8.1.3})

Thunderbird2.0
x86
Windows XP
fixed1.8.1, verified1.8.1.3
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
This may only be a problem for messages with only a single tag. I think it's IMAP only.

when I remove the tag, the message looks like the tag has been removed (i.e. the color in the thread pane goes away, the tag column loses the tag value), but the next time the msgview repaints the row, the tag comes back. 

I wonder if the keyword on the server is not getting cleared.
(Reporter)

Comment 1

12 years ago
we'd probably hold alpha for this I think.
Flags: blocking-thunderbird2+
(Assignee)

Comment 2

12 years ago
yes, I think that's what's going on. There's an other bug open about that, I believe.
(Assignee)

Comment 3

12 years ago
Created attachment 227112 [details] [diff] [review]
proposed fix

d'uh, go through the folder to remove the label, where we polymorphically do the right thing for imap.
Attachment #227112 - Flags: superreview?(mscott)
(Reporter)

Comment 4

12 years ago
Comment on attachment 227112 [details] [diff] [review]
proposed fix

excellent.
Attachment #227112 - Flags: superreview?(mscott) → superreview+
(Assignee)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Reporter)

Comment 5

12 years ago
*** Bug 342902 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 6

12 years ago
Hey David,

This checkin isn't showing up on bonsai for the 1.8.1 branch. Are you sure it went in there? :)
(Reporter)

Comment 8

12 years ago
Oh, ignore my earlier question.

This still doesn't work for me in today's 06/27 branch build then. I thought it went in this morning but I see it went into the branch and trunk yesterday. 
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 9

12 years ago
I reported this on 1.8 branch (2.0alpha1). This is on IMAP. (I could get more details on the server, if requested.) Whereas this report describes the tag as disappearing until a refresh of the thread pane, my experience is that the the message /flashes/--it loses the tag, loses the background color--but then instantly returns to the state where the tag is still applied, including the color. Subsequent tags can be applied and removed successfully, but the first one applied is locked.
(Assignee)

Comment 10

12 years ago
I've figured out what's going on here - we're not parsing the url to remove custom keywords correctly, so we're not removing the tags from the server. I'll code up a fix.
(Reporter)

Updated

12 years ago
Keywords: fixed1.8.1
(Assignee)

Comment 11

12 years ago
Created attachment 227430 [details] [diff] [review]
proposed fix

wanna try this out, Scott?
Attachment #227430 - Flags: superreview?(mscott)
(Reporter)

Updated

12 years ago
Attachment #227430 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 12

12 years ago
fixed on trunk and branch
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED

Comment 13

12 years ago
Now it's possible to remove all tags from IMAP messages in all my IMAP accounts. But now there is an JS error, when selecting a message from my Hosteurope IMAP accounts (only in these accounts) and the tags are not allways shown/listed in the message header:

Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgTagService.getKeyForTag]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://messenger/content/mailWidgets.xml :: buildTags :: line 993"  data: no]
Source File: chrome://messenger/content/mailWidgets.xml
Line: 993
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 14

12 years ago
Ups, the problem could be related to the different Thunderbird locales. My profile was created using a german Thunderbird, so the standard labels (now tags) have german names. Now I'm running todays en-US Thunderbird with my german profile. So the defined tags in prefs.js may have german pref-names and differ from what the en-US Thunderbird wants to use?

Comment 15

12 years ago
Creating a new en-US profile seems to work properly. So there must be a problem with the german standard tags - maybe a problem in encoding?

Here the lines out of my prefs.js:
-----
user_pref("mailnews.tags.$label1.color", "#FF0000");
user_pref("mailnews.tags.$label1.tag", "Wichtig");
user_pref("mailnews.tags.$label2.color", "#FF9900");
user_pref("mailnews.tags.$label2.tag", "Dienstlich");
user_pref("mailnews.tags.$label3.color", "#009900");
user_pref("mailnews.tags.$label3.tag", "Persönlich");
user_pref("mailnews.tags.$label4.color", "#3333FF");
user_pref("mailnews.tags.$label4.tag", "Zu erledigen");
user_pref("mailnews.tags.$label5.color", "#993399");
user_pref("mailnews.tags.$label5.tag", "Später");
user_pref("mailnews.tags.Gelb.color", "#FFFF00");
user_pref("mailnews.tags.Gelb.tag", "Gelb");
user_pref("mailnews.tags.Umlaut_Test_mit_&AOQA,AD8-_und_&IKw-_Euro.color", "");
user_pref("mailnews.tags.Umlaut_Test_mit_&AOQA,AD8-_und_&IKw-_Euro.tag", "Umlaut Test mit äüü und € Euro");
user_pref("mailnews.tags.version", 1);
-----

The standard tags are UTF-8 encoded, the individual created tags ("Gelb" and "Umlaut Test mit ......" have an other encoding. Could the UTF-8 encoding be the problem?

Comment 16

12 years ago
Thinking about this, the encoding can't be the problem. ALL standard tags have the JS error (independed from using encoded letters or not - e.g. "Dienstlich" and "Später"). Only the individual created tags (both with and without encoded letters) are working properly in the en-US Thunderbird.

In 2-3 hours todays german Thunderbird build will be created and I'm able to test my german profile with the german Thunderbird.

Comment 17

12 years ago
Yes, there must be a problem with the 2 locales:

The "Tags" column shows both words (the german AND the english). E.g.: "SpäterLater" or "WichtigImportant".

Comment 18

12 years ago
Sorry for spamming here, but it's so suspicious...

Now, after switching to another folder and switching back to the previous folder, Thunderbird shows only the english tags in the "Tags" column. In the first moment after tagging a message it shows both words/languages until I switch the folder.

Comment 19

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060629 Thunderbird/2.0a1 ID:2006062906

It looks like I can now remove tags, but when I apply one of the original labels (Important, for example) as a tag, it shows up twice in the message header in the message preview pane.
(Reporter)

Comment 20

12 years ago
(In reply to comment #19)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060629
> Thunderbird/2.0a1 ID:2006062906
> 
> It looks like I can now remove tags, but when I apply one of the original
> labels (Important, for example) as a tag, it shows up twice in the message
> header in the message preview pane.
> 

File a new bug on me for that. Thanks!

Comment 21

12 years ago
(In reply to comment #19)
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060629
> Thunderbird/2.0a1 ID:2006062906
> 
> It looks like I can now remove tags, but when I apply one of the original
> labels (Important, for example) as a tag, it shows up twice in the message
> header in the message preview pane.
> 

This is/could be related to my problems. Using the en-US only Tb/profile, I can see the english tag 2 times (e.g. "LaterLater"). Using the en-US Tb with german profile I can see the combination of both the german and english tags (SpäterLater).

Updated

12 years ago
Blocks: 343170

Comment 22

12 years ago
Filed bug 343170
No longer blocks: 343170

Comment 23

12 years ago
Filed bug 343179 - JS error by message tags, if using a Thunderbird locale in combination with a profile created with an other locale

Comment 24

12 years ago
We can re-close this bug again.
(Reporter)

Comment 25

12 years ago
cool.
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → FIXED

Comment 26

12 years ago
I think this bug needs to be reopened. Things appear to be somewhat broken again on the last several 1.8 (2.0a1) nightlies, at least in IMAP. I'm using it on OS X.

Steps to reproduce:

1) Tag a message in your Inbox as "Important" - actually any tag that has an associated color should work.
2) Right-click and select "Remove all tags" for the message.
3) Observe that the tag appears to have been removed, and the color is gone.
4) Click around a bit, or else just go view a different IMAP folder and then come back to Inbox.
5) The message will have regained the color from the tag applied in step 1. If you right-click on the message, it will show the tag checked once again. The tag will not be listed in the message header display though.

Comment 27

12 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1) Gecko/20061102 Thunderbird/2.0b1pre ID:2006110203

Tags are still not removing properly for me. It's still possible for me to produce duplicate tags on a message. This is observable on two different IMAP accounts.

I add a tag. Then I click to remove a tag (either using the keyboard access key or the tag sub-menu) and the tag appears to be removed. I navigate off the message and back on to it. The preview pane shows no tags in the header, but the tag color reappears on the message; the tag(s) reappear in the 'Tag' column of the messages pane. If I continue to try to remove the tags, I can get it down to a single tag. Sometimes the tags that are listed in the preview pane/header area do not match up with those reported in the Tag column. Occasionally, I can remove all tags.

How can I further confirm this bug? Would the names/versions of the exact mail servers be useful? I know one of the mail systems is titled Corvid. Both are in use at Carnegie Mellon University.
verified fixed 1.8.1.3 using Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.1.3) Gecko/20070326 Thunderbird/2.0.0.0 Mnenhy/0.7.5.0 ID:2007032620 and my m.c imap account. 

Removing tags on Imap Messages is working fine on Thunderbird 2 RC 2.
Keywords: verified1.8.1.3
You need to log in before you can comment on or make changes to this bug.