Closed Bug 342774 Opened 17 years ago Closed 17 years ago

Search bar starts too high then resizes

Categories

(Firefox :: Search, defect)

2.0 Branch
x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED FIXED
Firefox 2 beta2

People

(Reporter: ria.klaassen, Assigned: Gavin)

Details

(Keywords: fixed1.8.1)

Attachments

(2 files)

Every time when I start a branch browser it makes a jump. The toolbar gets higher because the searchbar gets higher.
Not the first start or the second but the third start after creating a new profile. Does not happen on a blank page so far.

A screenshot will make more clear what I mean.
Confirmed with and without Add-ons! It's highly annoying.

BUILD: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060626 BonEcho/2.0a3 ID:2006062605

~B
Regression between 1.8.1a3_2006061303 and 1.8.1a3_2006061404.
Weird that I didn't realize it before.
Commenting out http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/components/search/content/search.xml&rev=1.74&mark=291#287 fixes it, so setting the <xul:image>'s src attribute is what's causing the big jump. This is probably indirectly caused by the change from bug 337137, which added a better default image that had to be limited by a -moz-image-region. It seems like when we set the different icon, the -moz-image-region is temporarily removed and the search bar's size is increased to display the entire chrome://global/skin/icons/folder-item.png image, without actually displaying it.
Indeed, the search bar in the screenshot is 48 pixels high, which is the same height as chrome://global/skin/icons/folder-item.png (for windows).
Flags: blocking-firefox2?
Sometimes I can't reproduce it. And I found out that it is not reproducible when these prefs are present:
user_pref("privacy.sanitize.didShutdownSanitize", true);
user_pref("privacy.sanitize.promptOnSanitize", false);
user_pref("privacy.sanitize.sanitizeOnShutdown", true);
(In reply to comment #6)
> Sometimes I can't reproduce it. And I found out that it is not reproducible
> when these prefs are present:
> user_pref("privacy.sanitize.didShutdownSanitize", true);
> user_pref("privacy.sanitize.promptOnSanitize", false);
> user_pref("privacy.sanitize.sanitizeOnShutdown", true);

Perhaps clearing the cache makes the image take longer to load, or something like that. Either way, I've found that explicitly specifying the height fixes this bug, I'll attach a patch.
Assignee: nobody → gavin.sharp
Status: NEW → ASSIGNED
Attachment #228948 - Flags: review?(mconnor)
Severity: normal → minor
Whiteboard: [patch-r?]
Target Milestone: --- → Firefox 2 beta2
Attachment #228948 - Flags: review?(mconnor) → review+
Whiteboard: [patch-r?] → [checkin needed]
mozilla/browser/themes/winstripe/browser/searchbar.css 	1.12
Status: ASSIGNED → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Flags: blocking-firefox2?
Attachment #228948 - Flags: approval1.8.1?
Whiteboard: [need-a]
Attachment #228948 - Flags: approval1.8.1? → approval1.8.1+
Whiteboard: [need-a] → [checkin needed (1.8 branch)]
mozilla/browser/themes/winstripe/browser/searchbar.css 	1.3.8.8
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]
You need to log in before you can comment on or make changes to this bug.