emacs-style keyboard shortcuts don't work in html text boxes.

VERIFIED DUPLICATE of bug 229473

Status

VERIFIED DUPLICATE of bug 229473
12 years ago
12 years ago

People

(Reporter: livin.stephen, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.4) Gecko/20060613 Camino/1.0.2

Ctrl+A, CTRL+E, etc don't work in Camino's HTML Text boxes.

They DO work in the address bar, and in the google-search toolbar field.



Reproducible: Always

Steps to Reproduce:
1. Go to GMail.com. and in the 'username' field, type something. Then try CTRL-A to go the beginning of the text.
2. Try this with Safari.

The same shortcuts also DO NOT work within GMail's 'messages' box (where email is actually typed).

Nor does it work in this (https://bugzilla.mozilla.org/enter_bug.cgi, or
https://bugzilla.mozilla.org/show_bug.cgi?id=15351) page  itself - here the key combos are mapped to go straight to other text entry fields, so I guess that is a special case. 

Actual Results:  
The App/OS 'beeps' (or whatever the system-notification for invalid/erroneous keyboard input is) and the display flashes.

Expected Results:  
The caret should move to the beginning/end of the box.


this is similar to bug #339390 (which is marked invalid?)

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 229473 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.