Closed Bug 342889 Opened 14 years ago Closed 14 years ago

SessionSaver no longer working

Categories

(Firefox :: Tabbed Browser, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

VERIFIED FIXED
Firefox 2 beta1

People

(Reporter: jmjjeffery, Assigned: dietrich)

Details

(Keywords: fixed1.8.1, regression)

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060627 Minefield/3.0a1,Firefox
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060627 Minefield/3.0a1,Firefox

Starting with today's build the SessionSaver feature is no longer working.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060627 Minefield/3.0a1,Firefox ID:2006062704 [cairo]

Reproducible: Always

Steps to Reproduce:
1. Install the build from 2006062704
2. Note that sessionsaver no longer restores your session even with the hidden
pref's added to about:config 
3.

Actual Results:  
Only Homepage is loaded

Expected Results:  
Should restore your last session if you have enabled the hidden pref's
browser.sessionstore.enabled  true
browser.sessionstore.resume_session   true

This worked OK in the 2006062604 build. 
I suspect bug: https://bugzilla.mozilla.org/show_bug.cgi?id=328162 broke the feature. 

I have deleted all sessionsaver.ini sessionsaver.bak and storage.sdb files with no help. None of the files have been recreated after several closes/reopens of Minefield.
Keywords: regression
I get the following messages in the console on startup:
SessionStartup: The session file is invalid: [Exception... ""  nsresult: "0x804b000a (<unknown>)"  location: "JS frame :: file:///C:/<firefox directory>/components/
nsSessionStartup.js :: sss_init :: line 145"  data: no]

SessionStore: The session file is invalid: [Exception... ""  nsresult: "0x804b000a (<unknown>)"  location: "JS frame :: file:///C:/<firefox directory>/components/
nsSessionStore.js :: sss_safeEval :: line 1876"  data: no]

There is a sessionstore.js in my profile directory.  
I can't reproduce this on a Mac. Can you please post an example sessionstore.js file?
Assignee: nobody → dietrich
Attachment #227290 - Attachment mime type: application/x-javascript → text/plain
Don't click the attachment I added, it crashes Minefield... 
Yikes!!!  
Sorry... I'm still learning the hardway at times.

Don't worry about that crash.  It looks like it's a recent regression so it's not your fault.  I think it's due to bug 237085.

And you probably won't see the crash on a Mac because a bustage fix for that bug's checkin had this comment:
"Fixing bustage. Mac doesn't implement the fast GetTextDimensions ... sucks to be them"

I filed bug 342922.
I received the sessionstore.js files from the reporter, and was able to properly restore from it on Mac. Went through the same scenario w/ another windows user who could repro, which indicates that it's probably a windows-specific issue.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: blocking-firefox2?
Target Milestone: --- → Firefox 2 beta1
Well, maybe it's just me, but the attached sessionsotre.js file appears to be a single line with no line breaks that is over 18 killo-bytes in length.  I would suspect that could perhaps be causing an issue.
(In reply to comment #7)
> Well, maybe it's just me, but the attached sessionsotre.js file appears to be a
> single line with no line breaks that is over 18 killo-bytes in length.  I would
> suspect that could perhaps be causing an issue.
> 

It just happens to have lots of restore data, same happens with minimal sessionstore.js files. And since the same sessionstore.js files open correctly with mac it doesn't seem to be related to the saved files themselves.
I was initializing the sandbox with the raw file path instead of a proper nsIURI spec.
Attachment #227353 - Flags: review?(mconnor)
Attachment #227353 - Flags: approval1.8.1?
Comment on attachment 227353 [details] [diff] [review]
init sandbox w/ nsIURI instead of string path

please land this on trunk and get the fix verified with a tinderbox build
Attachment #227353 - Flags: review?(mconnor) → review+
This seems to be fixed in the latest hourly, thanks Dietrich
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060628 Minefield/3.0a1,Firefox ID:2006062811 [cairo]
Flags: blocking-firefox2? → blocking-firefox2+
Attachment #227353 - Flags: approval1.8.1? → approval1.8.1+
Keywords: fixed1.8.1
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Verified per comment 11.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.