Crash when loading plugin on intel macs [@ gPluginFuncsGlueTable]

RESOLVED DUPLICATE of bug 333950

Status

()

Core
Plug-ins
--
critical
RESOLVED DUPLICATE of bug 333950
12 years ago
7 years ago

People

(Reporter: Joachim Ante, Unassigned)

Tracking

({crash})

1.8 Branch
PowerPC
Mac OS X
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418.8 (KHTML, like Gecko) Safari/419.3
Build Identifier: 1.5.0.4

When loading our plugin on intel macs i get a crash. The crash doesn't happen on ppc macs and it also doesn't happen in Safari on intel macs. It has something to do with the initialization of the plugin.

If you have any more details on what is causing the crash i would like to hear about it and also work around it or fix the issue in the Unity Web Player.

This is the relevant stack trace i am getting when crashing.

0   <<00000000>> 	0x0df1a9a2 gPluginFuncsGlueTable + 2
1   org.mozilla.firefox      	0x0025b80b nsPluginHostImpl::TrySetUpPluginInstance(char const*, nsIURI*, nsIPluginInstanceOwner*) + 627
2   org.mozilla.firefox      	0x00252a8c nsPluginHostImpl::SetUpPluginInstance(char const*, nsIURI*, nsIPluginInstanceOwner*) + 44
3   org.mozilla.firefox      	0x0025a84a nsPluginHostImpl::InstantiateEmbeddedPlugin(char const*, nsIURI*, nsIPluginInstanceOwner*) + 1574
4   org.mozilla.firefox      	0x00535e25 nsObjectFrame::InstantiatePlugin(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, nsIPluginHost*, char const*, nsIURI*) + 637
5   org.mozilla.firefox      	0x00537748 nsObjectFrame::Reflow(nsPresContext*, nsHTMLReflowMetrics&, nsHTMLReflowState const&, unsigned&) + 1666
6   org.mozilla.firefox      	0x006e0820 nsLineLayout::ReflowFrame(nsIFrame*, unsigned&, nsHTMLReflowMetrics*, int&) + 810
7   org.mozilla.firefox      	0x0051ba9b nsBlockFrame::ReflowInlineFrame(nsBlockReflowState&, nsLineLayout&, nsLineList_iterator, nsIFrame*, unsigned char*) + 117
8   org.mozilla.firefox      	0x0051c1ae nsBlockFrame::DoReflowInlineFrames(nsBlockReflowState&, nsLineLayout&, nsLineList_iterator, int*, unsigned char*, int, int) + 718
9   org.mozilla.firefox      	0x0051c3cb nsBlockFrame::ReflowInlineFrames(nsBlockReflowState&, nsLineList_iterator, int*, int, int) + 171


Reproducible: Always

Steps to Reproduce:
Load http://unity3d.com/webplayers/Lightning/index.html and install the Unity Web Player.
Actual Results:  
Crash

Expected Results:  
Some 3d lightning effect  appearing in the browser window.
Component: Plugin Finder Service → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: plugin.finder → plugins
Version: unspecified → 1.8 Branch

Comment 1

12 years ago
If you read starting at comment 14 in the bug that I'm duping this to, you should be able to figure out what you need to do to fix this.

*** This bug has been marked as a duplicate of 333950 ***
Severity: normal → critical
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Summary: Crash when loading plugin on intel macs → Crash when loading plugin on intel macs [@ gPluginFuncsGlueTable]
(Assignee)

Updated

7 years ago
Crash Signature: [@ gPluginFuncsGlueTable]
You need to log in before you can comment on or make changes to this bug.