The document.write method in a new popup window does not complete the progress bar.

VERIFIED DUPLICATE of bug 81980

Status

()

defect
VERIFIED DUPLICATE of bug 81980
13 years ago
13 years ago

People

(Reporter: nosaku, Unassigned)

Tracking

({testcase})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4

The documemt.write method in a new popup window does not complete the progress bar. The progress bar stalls in the middle, as if it is expecting some more data.

It also shows a hour/watch glass mouse pointer when you move move the mouse near the toolbar in the new window.

Please see the attached test case and the screen shot.

In IE it works fine.


Reproducible: Always

Actual Results:  
Not completing the progress bar and showing a hour glass mouse pointer.

Expected Results:  
Must complete the progress bar and should not show the hour glass. As there is not more data expected etc.
(Reporter)

Comment 1

13 years ago
(Reporter)

Comment 2

13 years ago

Comment 3

13 years ago
Call document.close() to tell browsers that they don't have to expect more data.  IE expects more data too; it just never animates the throbber because of the possibility that there isn't more data.

*** This bug has been marked as a duplicate of 81980 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Keywords: testcase
Summary: The documemt.write method in a new popup window does not complete the progress bar. → The document.write method in a new popup window does not complete the progress bar.
(Reporter)

Comment 4

13 years ago
Thank you! And sorry for rushing the bug without first trying the document.close.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.