Closed Bug 343187 Opened 18 years ago Closed 18 years ago

DnD month view: Drop shadow for events spanning multiple days is not correct

Categories

(Calendar :: Calendar Frontend, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: ssitter, Assigned: jminta)

Details

Attachments

(2 files)

Fall out from Bug 324271:
DnD month view: Drop shadow for events spanning multiple days is not correct

Steps to Reproduce:
1. Switch to month view
2. Create normal event that span multiple days, 
   e.g. 05-Jun-2006 12:00 to 09-Jun-2006 12:00
3. Drag and Drop that event to another day, note drop shadows

Actual Results:
Drop shadows are not displayed correct. There are empty days shown between the shadows. The result looks like:
Day1|Day2|empty|Day3|empty|empty|Day4|empty|empty|empty|Day5|...

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060629 Sunbird/0.3a2+ (my own trunk build)
Attached image screenshot
Attached patch add 1, not iSplinter Review
Adding i is wrong, it should always be 1.  This also needs to be at the end of the loop (since before the first loop was adding 0).
Assignee: base → jminta
Status: NEW → ASSIGNED
Attachment #227700 - Flags: first-review?(dmose)
Comment on attachment 227700 [details] [diff] [review]
add 1, not i

r=dmose
Attachment #227700 - Flags: first-review?(dmose) → first-review+
patch checked in.
Status: ASSIGNED → RESOLVED
Closed: 18 years ago
Resolution: --- → FIXED
Works fine with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060721 Calendar/0.3a2+ --> VERIFIED
Status: RESOLVED → VERIFIED
Component: Internal Components → Calendar Views
QA Contact: base → views
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: