MathML crashes Minefield 3.0a1 cairo builds

RESOLVED DUPLICATE of bug 342533

Status

()

--
critical
RESOLVED DUPLICATE of bug 342533
13 years ago
13 years ago

People

(Reporter: jon, Assigned: rbs)

Tracking

({crash})

Trunk
x86
Windows XP
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060626 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060629 Minefield/3.0a1 ID:2006062916 [cairo]

Talkback IDs:

TB20428523K
TB20428684K
TB20428782Q
TB20429783H
TB20429841Y
TB20429882H
TB20429905G

Reproducible: Always

Steps to Reproduce:
1. Enter above data: URI to the address bar, which contains the following source:

<math xmlns="http://www.w3.org/1998/Math/MathML" display="inline">
  <mo>&lt;</mo>
</math>

2. Minefield (cairo and non-cairo) will crash
3. There is no step 3! :)

Actual Results:  
Minefield will crash with above TB IDs... doesn't matter is MathML is standalone as per test-case, or XHTML mixed mode pages such as: http://www.mozilla.org/projects/mathml/start.xhtml

Expected Results:  
Shouldn't crash!
Crashed for the first time somewhere between 1.9a1_2006062106 and 1.9a1_2006062113.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 2

13 years ago
This sure looks like bug 342533.  Can you verify that the crash is gone?

Bug 342533 doesn't depend on Cairo, though bug 324857 says that MathML on Cairo is all messed up.
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> This sure looks like bug 342533.  Can you verify that the crash is gone?
> 
> Bug 342533 doesn't depend on Cairo, though bug 324857 says that MathML on Cairo
> is all messed up.
> 

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060728 Minefield/3.0a1 ID:2006072806 [cairo] - Standalone & Mixed mode OK
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060728 Minefield/3.0a1 ID:2006072805 - Standalone & Mixed mode OK

Though as per bug 324857, MathML in Cairo is all messed up.
(Assignee)

Comment 4

13 years ago
Marking as dup per above comments.

*** This bug has been marked as a duplicate of 342533 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.