Clear private data...>Browsing History should also clear the 'Undo Close Tab' history

RESOLVED FIXED in Firefox 2 beta2

Status

()

Firefox
Tabbed Browser
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: Mathieu Pellerin, Assigned: Simon Bünzli)

Tracking

({fixed1.8.1, privacy})

unspecified
Firefox 2 beta2
fixed1.8.1, privacy
Points:
---
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060629 BonEcho/2.0a3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1a3) Gecko/20060629 BonEcho/2.0a3

Bug 254021 introduced a restore closed tab(s) function but the clear private data tool doesn't remove the closed tab history, potentially disclosing personal information reachable after leaving the user with a false feeling of having cleaned everything by closing the sensitive tab + cleaning browsing history.

Reproducible: Always

Steps to Reproduce:
1.Open two tabs, close one of them
2.Open the Clear Private Data tool, and clean the 'Browsing History' item
3.Go back to your main window and try to undo the last closed tab

Actual Results:  
The last closed tab shows up

Expected Results:  
All my previously closed tabs should be cleaned out

Comment 1

12 years ago
Should *disabling* history also disable the Undo Close Tab feature?
Flags: blocking-firefox2?
Keywords: privacy
(Assignee)

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

12 years ago
Created attachment 227775 [details] [diff] [review]
fix
Assignee: nobody → zeniko
Status: NEW → ASSIGNED
Attachment #227775 - Flags: review?(mconnor)
(In reply to comment #1)
> Should *disabling* history also disable the Undo Close Tab feature?

I don't think so, since we don't keep the previously closed tabs beyond a single session. But maybe. I'm just not sure that the user who doesn't want their browsing history recorded is also expecting to lose undo-close-tab functionality as a tradeoff.
--> blocking, TM beta2, will accept patches earlier if they're reviewed, landed and baked.
Flags: blocking-firefox2? → blocking-firefox2+
Target Milestone: --- → Firefox 2 beta2
Comment on attachment 227775 [details] [diff] [review]
fix

I'd rather use i than ix, to be consistent with the rest of the codebase, otherwise r=me
Attachment #227775 - Flags: review?(mconnor) → review+
(Assignee)

Comment 6

12 years ago
(In reply to comment #5)
> I'd rather use i than ix, to be consistent with the rest of the codebase,
> otherwise r=me

ix should be OK since we're not iterating over integer values but hash keys (which BTW is quite consistent all through nsSessionStore.js).
Whiteboard: [checkin needed]
mozilla/browser/components/sessionstore/src/nsSessionStore.js 	1.28
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed] → [need-a]

Comment 8

12 years ago
Is this check in for firefox 2.0 yet or only on trunk?

Updated

12 years ago
Whiteboard: [need-a] → [has patch][needs approval]
Comment on attachment 227775 [details] [diff] [review]
fix

Problem: the undo-close-tab data is not cleared when session history is cleared.

Solution: clear it out upon receiving the browser:purge-session-history notification.

Risk: Low
Attachment #227775 - Flags: approval1.8.1?
Comment on attachment 227775 [details] [diff] [review]
fix

a=drivers. Please land on the MOZILLA_1_8_BRANCH.
Attachment #227775 - Flags: review+
Comment on attachment 227775 [details] [diff] [review]
fix

a=drivers. Please land on the MOZILLA_1_8_BRANCH.
Attachment #227775 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Updated

12 years ago
Whiteboard: [has patch][needs approval] → [checkin needed (1.8 branch)]
This is checked in on branch, but unconfirmed in the latest build b/c clearing browser history is throwing errors. (I don't see them in my local build, just in the tinderbox build)

I'll look and see if this is related to this patch, or filed, etc.
Whiteboard: [checkin needed (1.8 branch)]
The error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsISHistory.PurgeHistory]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/bindings/browser.xml :: observe :: line 654" data: no]

Comment 14

12 years ago
(In reply to comment #13)
> The error: [Exception... "Component returned failure code: 0x80004005
> (NS_ERROR_FAILURE) [nsISHistory.PurgeHistory]" nsresult: "0x80004005
> (NS_ERROR_FAILURE)" location: "JS frame ::
> chrome://global/content/bindings/browser.xml :: observe :: line 654" data: no]

See BUG: https://bugzilla.mozilla.org/show_bug.cgi?id=342642

~B
Whiteboard: [checkin needed (1.8 branch)]
This is already checked in.
Keywords: fixed1.8.1
Whiteboard: [checkin needed (1.8 branch)]

Comment 16

12 years ago
Also... Shouldn't there be an option to enable/disable this in the configuration for "Clear Private Data" to be consistent?

~B

Comment 17

12 years ago
(In reply to comment #16)
> Also... Shouldn't there be an option to enable/disable this in the
> configuration for "Clear Private Data" to be consistent?
> 
> ~B
NM, I see this is tied to browsing history in "Clear Private Data".  Makes sense!

~B 

Comment 18

12 years ago
*** Bug 348566 has been marked as a duplicate of this bug. ***

Updated

11 years ago
Duplicate of this bug: 387487
You need to log in before you can comment on or make changes to this bug.